Recording new problems

I am using Audacity since many years. Some years ago I made many multitrack (I record one voice, than record an other, and so on) recordings without any problem.
Now I would like to do again the same, and got problems in some records. There are very short artifacts (about 100ms long) difficult to describe. It is like sound treatment is not good during this time. It seams that it appears more if I am recording a 4th or 5th track, and appears not offten (after 40-45s recording), however, if I repeat a recording the artifact seams to be at the same place!
I was using Audacity 1.2.6 and have just installed Audacity 2.0.5 without any change. I work under Windows XP SP3.
For the records, I use an extenal Sound Blaster Creative USB sound card.

First I suspected a disk space lack and liberate space without result.
Then I supected the antivirus, and uninstalled it, without result.
Then I updated Audacity, without result!

Now I do not have more ideas of what may be the problem origin, and any help/advice will be welcome.


PS: sorry for my poor English.

Please be careful with Windows XP. Microsoft are no longer officially supporting it, so it will be unpatched against any new security vulnerabilities (viruses) that appear. A virus may already
be causing your problem by using computer resources to spy on you or to use your computer to send spam e-mails over the internet.

Reinstall the anti-virus application immediately. Configure the anti-virus not to scan in Audacity’s temporary folder (in Audacity, look at Edit > Preferences… then “Directories” to see where the Audacity temporary folder is). If the anti-virus does not let you exclude directories or applications, obtain an anti-virus application that can do that.

Run a deep anti-virus scan that runs when you reboot the computer. But be aware that it will not give you complete protection against a previously unknown attack.

If it is not practicable for you to update to the much more secure Windows 7 or Windows 8, you can consider installing a Linux operating system instead. Most versions are free and all are very secure.

So it could be a playback problem and not a recording problem. What happens if you choose the built-in playback device in Device Toolbar ?

Make sure the USB cable is tight at both ends. Connect the cable to an empty USB port on the computer. Do not connect to a USB hub that has other USB devices connected to it.


Thanks for the answer.
During all the time I unstalled the antivirus to do the tests, I do not was connected to Internet. Then I reinstaled the Antivirus. I also tried to desactivate the antivirus when starting Audacit without connetion to Internet, without effect. I am very carefull concerning viruses and I am convinced that is not the problem.
I appologize beacause I do not understand what is the built-in playback device. During a record of a new track, I read simultaneously an other one, and have tried the two possibilities I have: “Mappeur de son Microsoft - Output” and “Sigma Tel Audio” (the PC portable internal sound Card) as output devices.
Ok for the USB connection, I have verified all you said!
Any other idea?

SigmaTel is the built-in sound device, but if you only see those two choices in Audacity for playback then Audacity can’t see SoundBlaster as a playback device.

I assume you would want to use SoundBlaster for playback? If so, restart Audacity. If you still cannot use SoundBlaster for Audacity playback, open Windows Sounds and Audio Devices to check.

How often do these artefacts occur? Does it occur regularly every six seconds? If so, it is probably happening when Audacity writes its recording data to disk. Can you export a few seconds of WAV audio so we can see and hear one of these artefacts. Please see here for how to attach files: .


Sorry, of course, the Sound Blaster is a third possibility, but it is my choice to do not use it! And I never used it.
It is verry difficult to say the rate of occuring of this artifact. The maximum I see is one after 40 seconds, and it is not always.
It seems to happen only, or more often, if there are already some recorded tracks (only one is read).
I have do tests by recording 1000Hz, and then I never heard an artefact?

I have also tested on an other computer with the same problem.
I am now trying to record without the Sound Blaster …

I add an 3 seconds mp3 (sorry I recorded the problem in mp3) to allow to hear the problem at about 1 second. It seems a short segment is missing.


If you don’t need the previous tracks to play when you record, try turning off Transport > Overdub.

If so that could indicate your computers are underpowered or you run too many other programs, but 1000 Hz will give you very muffled recording.

I don’t know what it is supposed to sound like if complete, but if you think the problem is a dropout, there are are many things you can try here: Missing features - Audacity Support .


“If you don’t need the previous tracks to play when you record, try turning off Transport > Overdub.”
I need one track to play, so I need Transport Overdub checked.
"If so that could indicate your computers are underpowered or you run too many other programs, but 1000 Hz will give you very muffled recording. "
I feared that, so that is why:

  • I do not run any other program,
  • I tested to disabled and completedly uninstaled the Antivirus,
  • I tested in same conditions on another computer (not a laptop).

Thank you for the verry interesting link.

Today I do not had a lot of time because I had to do real recordings! After some more tests, I have tried to work without the external sound card, and do not heard any artifact, but conditions where not exactly the same. Wait and see …

Thank you,

Also visit the Creative site and check if drivers are required for your SoundBlaster model. If so, ensure you have the last driver they made available for XP.



Very good idea. I will do that as soon as possible and try again. Not today, I have to start records in a few minutes!

Thank you,

I have installed the last driver I found on the Net, but do not know if it is newer than mine, and still have the same problem! !
Luckily I have an other way to work.

If you do need to check that, you could roll back to the previous driver in Device Manager and check its date or version number.


Thank you.
I do the check: my first driver dated 2001 and the new instaled dated 2005. So it was a good thing, however without effect on my problem. So i fear now that it is a problem in my sound card!