recording level too high or low, There's no gradation.

New here, and don’t have an option to post a message so I’ll do it here.

I have a problem with 2.3.1 levels. It’s either too low, or too high. In the previous version
it was fine, but now the volume is so low, even after processing, it sounds like I was on the other side
of the room. If I set it above 0.47 then it just clips. If I set it to 0.46 then it’s way too low. There’s
no gradation, it just jumps from too low to clipping.

So to find out if it was the mic, I uninstalled 2.3.1 and installed 2.2 and it worked fine. Put 2.3.1 back
on and the problem reoccurs.

Does anyone know how to fix this?

On a side issue, why can’t I set a hot key to apply macro now? It’s greyed out in the keyboard preferences.

Check that all sound “enhancements” are turned off. See:

Yes I see that too - not sure why, but I’ll ask the developer who worked on Macros.


He said …

‘Apply Macro’ probably should not be in there at all.
(it selects a sub menu)

Instead he/she wants the actual name of the macro he wants to apply.


The levels problem is that in 2.3.1 my levels are way too low, or clipping. There’s
no gradation. ie at 0.46 mic volume, it’s too low, even after processed it sounds like I"m
on the other side of the room. At 0.47 just 0.01 higher, it’s clipping.

In 2.2.1 this doesn’t happen. I uninstalled 2.3.1 and reinstalled 2.2 and it doesn’t happen
there, so it’s not a mic problem. Also, my OBS recording of the mic has fine levels. So what
is causing this in 2.3.1 and is there a way to fix it?

That’s silly. Then I’d have to apply a hot key to ever macro. A hot key for Apply Macro
let’s me quickly bring it up and choose one.

Don’t take away features, add to them!

If that’s what you want to do use the Macros Palette Tools > Apply Macro > Palette

This will leave the palette on screen all the time unless and until you dismiss it (or close Audacity)

Also note that its a resizable window, so if you have a lot of Macros you can make the window longer to avoid scrolling in the palette

See: Tools Menu: Apply Macro - Audacity Manual

I note that in the released 2.3.2 Manual it doesn’t mention the fact that it stays on-screen, or the resixability - I will fix that for the next release.

I do recall that when we had Chains (that Macros replaced) you could set a shortcut for Apply Chain - but when the developer who worked on Macros developed this he decided that the always-on-screen palette was a better idea than the shortcut for Apply Chain, which was always a one-time window that blocked other Audacity actions.


I understand this, however when you do this, you interupt our work flow. I don’t see the point
in removing a feature that people use. It’s a very control freak way of thinking. Effectively you
are saying, “You will use macros the way I intend you to, like it or lump it!” When the correct
philospphy is versatility to suit different work flows.

I still have not got one reply to fix my main problem.

What’s been removed?
The “Scripting and Automation” features in Audacity have been massively expanded.

What exactly do you want to do?
In Audacity 2.3.3 alpha on Linux, I can set hot keys to apply each macro, and I can set a shortcut to open the “Apply Macro Palette”, and I can’t set a keyboard shortcut to open the Macro Manager.

Perhaps we have a platform difference here. Could you give exact steps to reproduce.

That’s the inherent problem of asking multiple questions in the same forum topic.
My first reply was regarding your “main problem”.

OOH - so you can on Windows too.

Nor can you set a shortcut for “Apply Macro” directly - but the Palette is just as good if not better (especially as you can set a shortcut for it).



But note that this is the alpha Manual for the upcoming 2.3.3 release (we cannot edit any released Manuals).


but I can set a shortcut to “Macros…”

So to find out if it was the mic, I uninstalled 2.3.1 and installed 2.2 and it worked fine. Put 2.3.1 back
on and the problem reoccurs.

Does anyone know how to fix this?

That rules out windows enhancements

Just something to try.
Download zip version of 2.3.1
Unzip and create a folder called Portable Settings in the root of the folder before launching audacity from it - this means Audacity will be fully portable & settings will be self sufficient, then see if anything changes with your problem.


The macro was a side issue. For a week now, I’ve been trying to get an answer to my biggest problem, but all you talk about
is a macro side issue. I don’t care about that.

I can’t record anything as the levels jump from extremely low, to clipping, there’s no gradation. I tried it in 2.3.1, 2.2.1 and 2.1
and it’s the same. Everything was fine until I lost the power supply on my PC. It took out the boot sector on my C drive, but
that was fixed.

When it was all back up, I can’t record anymore as mic volume is all over the place. I use Voicemeeter Banana to control my audio
devices. I’m thinking the problem is the microphone, a RODE NT-USB which is only a year old and has been kept protected in
it’s dust cover when not used. Is this how Mics go out?

The banana thing is capable of automatically adjusting the gain before it gets to Audacity, e.g. “auto make up”.
If set incorrectly that auto-gain could make the audio go loud & distorted when it went above a (user defined) threshold,
giving you the effect you describe where the sound is either quiet, or loud&distorted, with no middle-ground.

It’s not the mic.

…all you talk about is a macro side issue.

Because that’s the one we have a fighting chance of fixing.

Your system is complex and those are always a real joy to service.

Do you use Chat, Conference or Skype? Games? Without going over the old posts again, is it a laptop? Do you like recording on-line content such as YouTube music—even if you don’t do it all the time?

If you said yes to any of those things, in addition to the banana, then you will never figure out what the problems is. Too much interaction.

Is this a laptop? Does it have a built-in microphone? Disconnect or turn off your external services, preamps, etc, and Shutdown (not restart).

Wait a bit and then Start. Don’t let any services or programs start. If you see programs automatically starting, make a note of them and prevent them from starting automatically and then shut down again. Isn’t there a place in the Control Panels you can choose which apps start?

If it’s a laptop, can you clean record from the built-in microphone? No automatic anything. Just select the microphone in Audacity and see if it behaves properly.

Auto volume setting can be apps trying to “help you,” but it can also be feedback caused by multiple sound pathways. This is the band at the club problem. Hello, hello…EEEEEEEEEEEEE.

One Way Out is stop using the latest Audacity. If you have something that works, hold on to it until there is a very firm reason to upgrade.

You can also get someone to help you unscramble the machine. We are trying to do it blind over multiple timezones.

Another desperation method is a different app.


Hi Kozikowski,

Thanks for your help.

Here’s a sample of the audio. It’s me going ahhh. The level is at 80%, and it’s barely audible and broken. Click the Down arrow top right to download it.


First off, Voicemeeter, the setup for that is the same as it was before the crash, so it’s not that. It was working fine before.

Second, it’s a desktop PC running Windows 7, and I’m using a RODE NT-USB mic, disconnect and reconnect devices I have done repeatedly.

Thirdly, I run a gaming YouTube channel, I use skype occasionally, and discord occasionally. I never record anything from online with the mic. It’s just for recording voice. There are no preamps, it’s a USB mic. Shutting down and restarting does not help the problem. These are all obvious things, I’ve already checked. As for startup, here is what is starting from Open CCleaner:

Yes HKCU:Run CCleaner Smart Cleaning Piriform Ltd “C:\Program Files\CCleaner\CCleaner64.exe” /MONITOR
Yes HKCU:Run RESTART_STICKY_NOTES Microsoft Corporation C:\Windows\System32\StikyNot.exe
Yes HKCU:Run Sidebar Microsoft Corporation C:\Program Files\Windows Sidebar\sidebar.exe /autoRun
Yes HKCU:Run Skype for Desktop Skype Technologies S.A. C:\Program Files (x86)\Microsoft\Skype for Desktop\Skype.exe
Yes HKCU:Run Steam Valve Corporation “C:\Program Files (x86)\Steam\steam.exe” -silent
Yes HKLM:Run AdobeAAMUpdater-1.0 Adobe Systems Incorporated “C:\Program Files (x86)\Common Files\Adobe\OOBE\PDApp\UWA\UpdaterStartupUtility.exe”
Yes HKLM:Run APSDaemon Apple Inc. “C:\Program Files (x86)\Common Files\Apple\Apple Application Support\APSDaemon.exe”
Yes HKLM:Run Bdagent Bitdefender “C:\Program Files\Bitdefender\Bitdefender Security\bdagent.exe”
Yes HKLM:Run BdVpnApp Bitdefender “C:\Program Files\Bitdefender\Bitdefender VPN\BdVpnApp.exe”
Yes HKLM:Run HDAudDeck VIA C:\Program Files (x86)\VIA\VIAudioi\VDeck\VDeck.exe -r
Yes HKLM:Run IAStorIcon Intel Corporation C:\Program Files (x86)\Intel\Intel(R) Rapid Storage Technology\IAStorIcon.exe
Yes HKLM:Run Start WingMan Profiler Logitech Inc. C:\Program Files\Logitech\Gaming Software\LWEMon.exe /noui
Yes HKLM:Run SunJavaUpdateSched Oracle Corporation “C:\Program Files (x86)\Common Files\Java\Java Update\jusched.exe”
Yes HKLM:Run USB3MON Intel Corporation “C:\Program Files (x86)\Intel\Intel(R) USB 3.0 eXtensible Host Controller Driver\Application\iusb3mon.exe”
Yes HKLM:Run XboxStat Microsoft Corporation “C:\Program Files\Microsoft Xbox 360 Accessories\XboxStat.exe” silentrun
Yes Startup User Voicemeeter (VB-Audio).LNK VB-AUDIO Software C:\Program Files (x86)\VB\Voicemeeter\voicemeeterpro.exe

To test, I uninstalled various codecs and 264vfw_full_42_2538nm_41390.exe and the problem resolved itself. Then I went looking
for hard limiter, because it was missing, a post here lead me to audacity 2.3.2 which they said had it, and after installing that,
the problem with the microphone returned. I reinstalled the above codec, tried uninstalling it but no help of course.

So now I’ve gone back to 2.3.1 and I reset the preferences and that caused the problem to changed. Instead of the sound going from too low to clipping, it’s now just waaay too low and broken (mic volume drops out and comes back on it’s own) regardless of where the levels are set. This is what I have done to try to trace the cause:

  1. Check and test levels of the device
  2. Check and test levels of the voicemeeter banana device
  3. uninstalled all codecs/plugins
  4. reinstalled all above.
  5. Uninstalled and Reinstalled Voicemeeter Banana and reloaded my setup.
  6. Disabled Windows from changing the volume of the microphone in mic properties
  7. No apps are allowed to auto-change the mic volume. ie skype, or discord. Audacity is not set to voice activation.

An interesting point in Voicemeeter on The Comp AUDIBILIY Gate is when it’s set to 10, the mic cuts out completely on the right channel
only. The levels of the left and right channels are also different and I don’t seem able to change that in Voicemeeter. Increasing the left
increases the level of both, when I would’ve thought it’d just increase the left. I don’t know if that is important or not.

As of now; I am out of ideas. I don’t have any application that works. For awhile 2.2 worked, but now ALL version of Audacity have the same problem down to 2.1, I’ve not tested previous version as they are of not much use to me. I wouldn’t be opposed to changing apps, however before
I did, I’d want to make sure it’s Audacity that is causing the problem. At the moment, I’m not sure. It’s very frustrating. Especially
since tomorrow is going to be another upload missed for my channel. :frowning:

Your machine is oscillating. Your description of the problem is of a clean pure voice that snaps between too loud and too soft once as you adjust the volume with no setting possible in the middle. I hear a badly unstable sound system pounding away eight times a second. Those two are very different.

Audacity > Edit > Preferences > Recording. Turn off Overdub and Playthrough > OK.

Did that help or change?


Thanks for the reply.

Overdubbing isn’t the problem, althrough it was ticked, on disabling it, it didn’t fix the problem. I have managed
to make an improvement, but the audio quality, is nowhere near as good as it was, and the volume is still
too low, even after processing. Messing with the levels causes it to break up again.

At the moment, I can record again, but the volume is very low.

If your Complete Noise-Free Recording Volume is greater than 0.5 and less than 1.00 and the Recording Level pushes up above ‑15dB but not higher than ‑3dB when you speak, then perfect – you’re done with your adjustments! Use your Complete Noise Free Recording Volume determined in step 4 as your Final Recording Volume. Every time you start Audacity to record, confirm that the Recording Volume is set to this level.