Recording level drops to zero after a few seconds then Audacity displays error when try to resume

Start Audacity build 3.3.3, MacOS Ventura 13.4.1, Macbook Pro with Apple M1 Pro chipset. Select recording device to iMic USB Audio System (I’ve used this in the past and no problems). Microphone recording level set full - all the way to the right. Start recording, after a variable period of time but varying over several attempts by 5 - 48 seconds, the level slider goes all the way to the left and the recording level showing on the track almost flatlines. Stop recording. Move the slider back to the right. Try to resume recording. Get an error message pop up; “Error opening recording device. Error code: -9986 Internal PortAudio Error.” Restart Audacity, try again, same again. Now I tried again but this time when the level slider dropped, I kept recording and slid it back. This made no difference; the actual recording level as shown by the track waveform didn’t change, confirmed when played back.

I made a 90 second video showing what happens. Video showing problem

What changed? Was it the upgrade to Audacity 3.3.3 or to macOS 13.4.1?

I’m surprised you’ve managed to keep the iMic going this long. It has long been discontinued by Griffin.

I didn’t use Audacity for a while and have upgraded to 3.3.3 and to MacOS. The iMic works fine with other applications such as recording in Camtasia or Snagit. I did consider trying to install a legacy version of Audacity but figured it would be better first to get the thoughts of the help forum community. Now I’ve just tried something else; I started recording from the Macbook microphone, all was fine for 1min 34 seconds. I stopped recording, no problem. Switched to the iMic, started recording. 12 seconds later, the problem appeared. So it looks like the iMic is the problem. I’ll have to find an alternative to plug in my lapel mic; any recommendations?

Hi folks. I bought a SoundBlaster interface 3.5mm to USB 2.0. This seems to work fine so I can bin the iMic. The error message doesn’t appear either when I try to re-start recording. Thanks all.

This topic was automatically closed after 30 days. New replies are no longer allowed.