Recording/Latency Problem.


I’ve started using Audacity to record some vocals.
I’m using a Behringer C-1U Condensor Microphone (USB). - My Operating System is Windows 7

I’ve had no problems up till today, when i tried recording, and the message:
‘Latency correction setting has caused the recorded audio to be hidden before zero. Audacity has brought it back to the start. You may have to use the Time Shift Tool (<—> F5) to drag the track to the right place.’ keeps appearing.

If i open an MP3 track, or backing track, with audacity, it has no problem playing it, it only happens when i go and click the ‘Record’ button. It sits at the start of the track, not moving and flickering.
I have gone to Audacity Preferences and changed the Latency settings but nothing has changed. And i have also used the Time Shift Tool, but it hasn’t worked and it keeps going back to the same place.

I have no idea how to fix the problem. What am i doing wrong?

Thanks alot for your help. :smiley:


Audacity has found what it thinks is a valid recording device, but it’s not receiving any data from it, so when you try to record the cursor just sits at the start waiting for some data (which never comes).

First, have a look in the Windows Control Panel and ensure that your USB microphone is recognised by Windows and is enabled (see here: ). If it is, then check the recording format that it is set for - it should be set to “16 bit 44100 Hz (CD Quality) Mono”.

Note that the microphone must be recognised by Windows before you open Audacity.

Then open Audacity an go to “Edit menu > Preferences > Devices” and ensure that the “Recording” device is set to the USB microphone and the “Playback” device is set to your normal sound card.

Then in “Edit menu > Preferences > Quality” ensure that the default sample rate is set to 44100 Hz and the default sample format set to 32-bit float.

Finally, look at the bottom of the Transport menu. “Software Playthrough” should be off (not selected) and “Overdub” should be on (selected).