Recording issue (mono vs stereo)

This has probably been asked a 1000 times already but I was not able to find a topic with a proper solution.

I am recording from a Pioneer DJM mixer to my laptop using audacity. See screenshot below. The recording input (red bars) shows input from both left and right channel. The soundtrack that I am recording however only records left. On the DJM mixer there is a balance knob. When I turn this to the right the input for the whole track is gone. Somehow right channel is not recorded but everything is set to stereo. What could I do?

Any help is much appreciated!

My guess is that you have plugged the output of your mixer into a mono microphone input on your laptop. That would account for both the recording being mono, and the recording level being too high.

Thanks for your reply steve. I have been using the same laptop for 2 years and only recently the problem appeared. Also, when I open a random mp3 in audacity and click on the audiotrack dropdown (audiospoor in my screenshot) it also only ticks left channel (linker kanaal)… This makes me to believe it is not an issue of the microphone.

Yes, but that is greyed out. Greyed out controls are not applicable. In two channel tracks (as shown in your picture) the upper part of the track is the left channel and the lower part of the track is the right channel. The greyed out tick is irrelevant (which is why it is greyed out).

So is your DJ mixer plugged into the laptop mic input?
That is not generally recommended as the mic input on most laptops are designed for connecting a mono computer microphone (which produce a much smaller signal than a mixing desk, and computer microphones are nearly always mono).

On some laptops, the “mic” input can be used as a stereo line level input, but the sound quality is often not very good, and you need to set the Windows recording level to a very low level, and tell Windows to record from the device in stereo. Those settings are in the Windows Sound Control Panel.

Again, thanks for your efforts steve. Yes, my DJ mixer is plugged into the laptops microphone input using a 2 tulip → 3.5mm jack cable. The cable is fine, i have checked that.
I read through the document you linked to. I went to the windows audio settings as you told me. Microphone properties → advanced. Here I could select the samplefrequency. All options are 2 channel, 16 bit. Only the Hz values are different. I could not select a mono or stereo option here. But, as all microphone input options are 2 channel, I believe that it supports stereo?
In the “Improvements” tab, I see a option “Cancel DC”. The description of this option says something about using the right level on the input signal. I have tried switching this option on and off without any result.

Do you have any more suggestions? Thanks a lot anyways.

I’m running out of ideas, but the cable is a likely culprit. How did you test it?

Lol. Steve, never mind. I have called ASUS customer support. It is indeed a mono microphone. Thanks anyway.

Ideally what you need is an audio device with “stereo line level inputs”.
I use a Behringer UCA 202, which is very inexpensive and does a good job. There are lots of other makes/models at all price ranges, but anything under $20 is likely to be rubbish :wink: