Recording issue, help plesae [SOLVED]

Everything seems to be functioning well. I’ve downloaded the most up-to-date audacity software. I hit record on Audacity, then play on the cassette player, then stop them both after the 20 seconds I’m trying to record. But when I listen back it’s complete silence. Audacity does run, it shows all the action on the screen, bu tit isn’t ‘hearing’ what I’m playing. The USB is connected. Just trying to figure out what I’m missing. Help please, thanks. It’d be greatly appreciated.

It doesn’t take 20 seconds to test your connections. Audacity has a diagnostic tool.

The right-hand, recording sound meters are red (while they’re working). You can right-click inside them anywhere > Start Monitoring. The meters are now active and if you play the cassette machine, the meters should start jumping.

For you , they may not.

If you have the cassette machine connected and all the right lights come on, restart Audacity. Audacity looks for sound devices when it starts.

Then go to the Device Toolbar and make sure your USB device is listed and selected.

Any better?


Thanks for your attempt at assisting me, it’s greatly appreciated. Unfortunately it seems I did a bad job of explaining the problem. The 20 seconds I reference is in reference to the length of the cassette recording that i’m trying to transfer to my computer. I checked, and it’s actually 28 seconds, for the sake of accuracy. It’s an old answering machine message from my now deceased grandfather. So the problem is that it seems as though Audacity is functioning fine when I hit record, only it doesn’t record what’s coming from the cassette, just static.

If it helps, the settings are MME, Speakers/Headphones (IDT high), Integrated Microphone Array (ID) and 2 (Stereo) Input Channel. These are the default settings. I’m on Windows 7 Home Premium. Perhaps I need to adjust some of the settings? Just a guess, I’m lost.

But just to be clear, when I click the record button on Audacity (and hit play on the cassette), Audacity acts as if it’s recording, and the Red bars on the top right show what I imagine is normal activity. And on the playback the green bars show activity but only static is audible.

I’m assuming that either I need to switch one of the settings, or that Audacity isn’t recognizing the device. I’m assuming the latter because I tried hitting ‘record’ on Audacity without running the cassette player and it does the same exact thing. It creates a file for as long as I allow it to run, and it plays back with the same static. So most likely I need to figure out how to get Audacity to recognize the device. I tried restarting it, per your advice. Any other ideas? I really appreciate your time, thanks again.


And there’s your problem. You want to record from the USB tape player but you are choosing the internal microphone of the computer to record from.

So choose the USB Audio CODEC as Koz said, instead of the Mic Array.

If you don’t see the USB Audio CODEC in Audacity, restart Audacity.

If Windows doesn’t see the USB Audio CODEC, follow the steps in the green box “Detecting USB and Firewire Audio devices” here: Audacity Manual .


Sweet, that solved the problem, thanks!