recording is silenced every 6 seconds [SOLVED]

I have version 2.0.5.

When I make a recording (p.e. music), Audacity first records the music for about 6 seconds, then erases the recorded sound and starts recording the next 6 seconds etc. So after 18 seconds I have only the last 6 seconds of music and the first 12 seconds are mute (still).
And that’s not all: when I stop the recording, I lose everything. All I get is a 18 seconds of silence.

I first had that problem yesterday, with an old version (1.3). Now I installed the latest version from .exe, but I’ve still the same problem.

Thanks for your help!

Look at Edit > Preferences… then Directories for the location of the Audacity temporary folder.
Audacity isn’t able to write there, either because the drive is full, or the drive is not working correctly, or you do not have permission to write there, or some cleanup application is monitoring that folder and deleting files as they are created.

Choose a new location that has plenty of space and make sure you have permission to write there. If necessary, tell your cleanup program not to scan there.

The default location of the Audacity temporary folder on Windows Vista and later that should work correctly is:

C:Users<your user name>AppDataLocalTempaudacity_temp

If you need more help, please say what version of Windows you have.


Thanks, Gale! I changed the location for the temporary files, and the problem seems to be solved now.
I’m not aware of any cleanup tool that is running on my PC (Windows 7) , and the default temporary folder was in a partition of my hard disk with more than 45 GB of free space. But anyway, I created a new folder in another partition, and now things work properly.