Recording in Audacity with DragonFly Red connected

My Windows 7 PC has a Realtek High Definition audio card on the motherboard. I purchased an AudioQuest DragonFly Red external USB audio card. With the DragonFly attached to my PC, Audacity will playback through the DragonFly USB speakers but it will not record audio from my PC. I’ve tried the different input source settings in Audacity but nothing changes.

I’ve attached screenshots of the input source, microphone, and speaker dropdown options in Audacity. The only change with or without the DragonFly is the name of the output speakers.

All of the input source options work without the dragonfly when recording in audacity. None of them work with the DragonFly attached.

I’m not sure what settings to change in the Windows Sound options to get Audacity to pick up the audio coming from my PC. Any assistance would be appreciated.

Audacity - with DragonFly.png
Audacity - no DragonFly.png

Try [u]WASAPI (loopback)[/u]

Note that WASAPI (loopback) won’t record if there is no audio stream so you may have to start the audio playback first.

Two things:

  1. Make sure you start Audacity after plugging in your Dragonfly (otherwise do Transport > Rescan audio devices)
  2. Check to make sure you have Windows permission to use the microphone:

Thank you for your feedback.

I did start Audacity after I plugged in the DragonFly. In the screenshots I didn’t have the audio playing as I was only trying to show the options I had for the input source.

I have attached screenshots that show recording audio with both the DragonFly and without. I tried all the different settings with the DF and none of them work.

Audacity with DragonFly - MS Sound Mapper Option.png
Audacity with DragonFly - Stereo Mix Option.png
Audacity without DragonFly.png

Sometimes under WASAPI, there is a Speaker loopback selection which is going to be similar to Stereo Mix.

Thanks jademan, that worked. I selected WASAPI and the DragonFly loopback option and the Audacity is able to record the input.

I think DVDdoug mentioned it before but I didn’t pick up on what he was saying.

Thanks to all for your feedback and assistance!
Audacity with DragonFly - WSAPI & Loopback Options.png

Yes, DVDdoug is very knowledgeable. :smiley: Glad you got it working. :smiley: