Recording help - records all noises in room

This problem is driving me to the point of smashing up my computer.

I am trying to record from the Djay app on iPad to my PC via a Pioneer mixer.

The problem I have is the recording picks up every noise in the room I.e. My voice / general noises.

How do I eliminate these noises so the only media recorded is the music. Is this possible?

I’d be grateful on how I should be setting up with cables/ settings on Audacity. Do I need to do anything with the PC settings on Realtek/ audio devices?

Thanks in advance


This problem is driving me to the point of smashing up my computer.

Get somebody to make a video when you do that. Can’t have too many purple rage, smashing-up videos.

Which mixer? Model number? Is it connected with USB? Are you plugging it into the Mic-In of your laptop?

It’s a terrifically good chance you’re recording the laptop built-in microphone rather than the mixer connection. That will record the metrobus outside and the dog barking.

Where we go from here depends on the answer to those questions.



Mixer = pioneer wego 3

It’s connected to PC as follows -

Twin phono cable to single jack. Jack connects to splitter which is connected to speaker. The other jack on splitter I have a male to male cable connecting to my PC.

I have 2 options on my PC, headphone or microphone.

It seems for any sound to record I have to connect to microphone.

Whatever I do with audacity is replicated with the inbuilt PC sound recorder used in conjunction with the Realtek software.

Kind regards


Try disabling the computer’s built-in microphone.
No smashing required : you can disable the built-in mic in Windows “Recording devices”.

If that leaves you with no recording devices, see if you can enable the external microphone. To do that, right-click anywhere inside the Recording tab of Windows Sound and choose “Show disabled devices” then right-click again and check “Show Disconnected Devices”.