Recording from USB turntable and cassette garbled

I decided to digitize my LPs and cassettes on my new computer. I connected the USB turntable, installed Audacity, and was pleased with the results for the first four records. I came back a few days later and could only get garbled sound when I tried to record. The sound coming out of the turntable was fine, but the recording on Audacity was not. The recordings I’d done on the first day still played well, but if I tried to re-record those same records, it was a mess. Here’s what I’ve tried so far:
I’ve tried reinstalling Audacity, sound drivers and USB drivers.
I have rolled back Windows updates.
I’ve tried every USB port.
I’ve tried a different USB cable.
I have tried the USB cassette instead of the turntable.

Nothing has worked. Help please!

Make sure you’ve selected the correct USB [u]Recording Device[/u]. (You shouldn’t be using “Stereo Mix” or “Loopback”, and of course you shouldn’t be using the microphone built-into your laptop.)

Or, sometimes Windows tries to improve the sound. Make sure [u]Windows “Enhancements”[/u] are turned OFF. (Sometimes these are enabled when you use Skype or another communications program.)

If none of that helps [u]post a short sample[/u] so we can hear what it sounds like.

Thank you! Removing Windows enhancements did the trick!