Recording from previous tracks transfer to new automatically

Hi! I"m trying to record several instruments, with each instrument having its own designated track. When I open a new track and record rhythm guitar, then add a new track to record bass guitar, the audio recorded from my first track automatically records onto my second track. When I open a third separate track to record lead guitar, the audio recorded from the first and second track is automatically transferred to the third. When I playback audio from all three tracks it sounds like the previously recorded instruments have been twinned, or stacked, meaning playback of the third track sounds like I have three rhythm guitars, two bass guitars and a lead. When I add a new track for drums and playback after the drums have been recorded, all of the previous instruments from the above tracks have multiplied with each added track and sounds muddy and more distorted with each new track. I want each instrument alone on it’s own track so I can eq each track separately. I have spent hours searching through the menu, options, preferences, faq, etc. on how to stop this, but to no avail. Please help!

Audacity > Edit > Preferences > [X] Overdub… That should be the only thing selected.

Do you like to record YouTube or other on-line sound? Those sound settings can mess up overdubbing. Make sure you’re recording directly from your instrument or other digital interface, not a fold-back “fake” device such as Stereo-Mix or What-U-Hear. Set that with the Audacity Device Toolbar.

This is the worst thing to correct because it’s basically open-ended. “Do you remember how you set up your computer to record YouTube sound? Don’t do that.”

In my case, I’m recording from "USB Audio CODEC" because that’s the digital name of the little USB sound adapter that connects the sound mixer I use for overdubbing.

Windows has pages of settings that can confuse this process. See if that helps.