Recording from microphone only

This might be more of a Windows problem, but it’s affecting using Audacity and it’s frustrating me. I want to do something very simple: Just record a track through the laptop microphone while another track is playing through the headphones. It doesn’t have to be great fidelity; this is just for a test. However, I do want the track that’s recording the microphone sound to have only the microphone sound rather than mostly being a copy of the other track with a tiny bit of microphone sound.

Anyway, when I try to do this, whatever sound the computer is making is getting onto the track that I’m recording, so basically it’s mixing the computer-generated sound (about 80%) with the microphone sound (about 20%). This is not because it’s coming from the headphones; even if the headphones are far away from the microphone, one gets mostly sound from the computer. No sound is coming from the computer speaker, so it’s clear it’s not going to the microphone through sound waves. Somehow, the computer is mixing the sound that it’s generating together with the input from the microphone. This happens also if the computer makes other sounds; for example, if I have Media Player playing, what gets recorded is the sound from Media Player together with what’s coming through the microphone.

This is a Dell laptop with Windows 7 installed. Most things online that might relate to anything anywhere close to the problem are apparently for Windows XP. I’ve tried playing with the settings under “Sound” and “Realtek HD Audio Manager” in the control panel, but nothing solved the problem. Specifically, I tried disabling everything that says “Stereo Mix,” both in “Sound” and “Realtek HD Audio Manager.” This is what most things I read online led me to believe I should do. However, that has absolutely no impact. I also tried turning off “overdub” in Audacity, but all that accomplishes is that it causes the other tracks to be silent, and any other noise the computer is generating still gets mixed in together with the microphone input.

Any ideas?

Any ideas?

Certainly. You want the standard Overdubbing configuration. Track one (for example) plays cleanly into your headphones and Audacity will create a new clean track with your microphone. This can fall apart if you like to run your headphones at ear-splitting volume. Your head will leak sound into your microphone. Oh, yes it does. It’s a problem for rock performers.

You need to know that the computer by itself will not feed you back to yourself in real time unless you got really lucky. There’s always a delay. Plus you need to set Recording Latency. It’s all in the descriptions.


Thanks. It’s definitely not bleed-through from my headphones…The volume is set very low, and it happens even if I put the headphones very far from the the mic. The sound from the computer output gets recorded loud and clear, not as if it were coming through the mic. I have overdub on, and software playthrough is off. All I need is for the recording to only contain what’s coming through the mic and not any sounds being directly passed from the computer. I don’t need to hear myself in the mix.

Most likely it’s a Windows problem, since I see tons of posts in the Internet by people who have similar problems in Windows 7 / Realtek audio, except no cases where anyone has a good answer. You’d think that for something so basic as this, someone would have figured this out by now, but apparently not.

I was hoping though that maybe it was some simple setting…something I overlooked, or some switch I could turn in Audacity or something…

One of the things we did early on in the Overdubbing tutorial is to get you to do a straight, uncomplicated recording. It’s amazing, but maybe not to you, how often that fails and it usually fails because the computer isn’t recording the microphone. It’s recording one of the software “fake devices” like Stereo-Mix or What-U-Hear.

I call them magic because they’re not physical devices. You can reach out with your finger and touch Mic-In. It’s that little pink connector at the side of your computer. You can’t do that to Stereo-Mix. It’s a software routing program inside the computer, not a physical device.

These are the systems used to allow the computer to record internet audio. They run the playback and record sides of the computer at the same time, in effect, playing to the speaker and then turning around the sound and sending it down the recording path. That’s precisely what you have. Audacity is being forced to record “What’s Playing On The Computer” instead of your microphone. That should be fixable in the Windows Control Panels.

Oddly, as you found, there’s no formal instructions to fix that, but I can recommend the instructions to force that to happen and you should follow those instructions backwards.