recording flatline with UR12


My microphone does not record sound in Audacity - ie I get a flat line, even though I notice the green bars of the microphone volume go up in the top right volume bar in Audacity. Can anyone help?

- Computer Configuration:
Audacity 2.1.0
Windows 10 Home Edition (up to date), with the following sound controllers in the Device Manager:

  • Hauppauge Win TV HVR-5525 (that’s an internal TV tunercard with which I watch TV on my computer)
  • NVIDIA High Definition Audio
  • Realtek High Definition Audio
  • Steinberg UR12

- Microphone:
Behringer ECM 8000 connected to a Steinberg UR12 pre-amplifier, which in turn is connected to my computer via USB.
I already installed the latest driver for UR12 pre-amplifier, and the microphone does visually register the sound in SpectrumLab (, but it doesn’t record it in Audacity.

- Headphones:
Logitech headphone via the rear jack of my computer. Realtek recognises it. When I connect it, gives me a choice between “headphone” and speaker", and regardless of which option I take, it is listed as “speaker”. The headphones work, I hear the sound properly with other applications.

- In the Control Panel > Hardware and Sounds >

-------- Playback, listed are:

  • Line (Steinberg UR12) - Disabled (enabling it makes no difference)
  • NVIDIA Output - not plugged in
  • NVIDIA Output - not plugged in
  • Speakers Realtek High Definition Audio - set as default device

-------- Recording, listed are:

  • Line Steinberg UR12 set as default device
  • Microphone Realtek High Definition Audio - not plugged in
  • Line in - Realtek High Definition Audio - not plugged in
  • Sterio Mix - Realtek High Deinition Audio - disabled (enabling it makes no differnce)

Actions taken so far, without success:

  • Driver updates of UR12 (ver 1.10.0) and of Realtek

  • Setting up headphones as headphone or speakers in rear jack - in both cases listed as “speaker” in the Playback Devices, no effect in Audacity.

  • Changing the Windows settings (Control Panel > Hardware and Sounds > Sounds) of Playback and Recording, flagged and unflagged Exclusive Mode and Enhancements in their Advanced settings etc., each time either restarting Audacity or Transport > Rescan Audio Devices after a change

  • Audacity is set to microphone Line Steinberg UR12,stereo (I tried mono too) and as speaker Realtek High Definition Audio.

- Question:

Does anyone have any suggestions as to how I can get the microphone to record in Audacity? Thanks!

how I can get the microphone to record in Audacity?

If the bouncing green sound meters in Audacity are moving and you get blue soundwaves when you record, you are getting a show whether or not you can hear it.

I don’t know why the headphones don’t work I need to read that again.


The green volume indicator lights up when recording,
but the sound recording (where you have the blue spectrum of the sound on your screen capture) is a complete flat line.

Here is a screen capture that illustrates the problem:

is a complete flat line

That’s not surprising. The default timeline only recognizes the loudest 30dB (approximately) out of the possible 96dB of sound. That’s useful because if your presentation isn’t in the top 30dB, it’s likely to be too damaged for a show.

Close Audacity for a minute.

Windows > Right-Click Speaker (lower right) > Recording devices.

Do you see your system in that list and does the little green sound meter bounce when you make sound? Note, never blow into a microphone. I scratch the wind screen.

Audacity gets its sound from Windows, not the device.

If that’s OK, launch Audacity and click inside the green recording meters. Do they bounce in time to you scratching? What does the device say just to the right of the Audacity little microphone symbol?

If it’s still no joy, sound systems have been known to ignore each other if you cross Stereo and Mono by accident. I believe the Steinberg is a native mono device, so it should be possible to set up everything for mono and get it to record.

If still no joy, I’m out. I’m not a Windows elf and if you have odd Windows problems, I’m not good with those. I do know if you saw the word “ASIO” in your driver management, that’s probably not a good sign. Audacity does not work with ASIO drivers.

We should wait for a Windows elf.


I would switch the system to mono and drag it back from those super high settings to 16-bit, 44100, Mono.Those first two numbers are the settings for audio CD and are as common as dirt.

Audacity > Edit > Preferences > Devices: Mono. > OK.

Audacity > Edit > Preferences > Quality: Sampling > Rate: 44100, Format: 16-bit > OK.

That work any better?


Thank you.

  1. This is a screen capture of singing (half) a scale (do re mi fa sol la ti do ti la sol fa mi re do) in Spectrum Lab. So the microphone does pick up sound
    Spectrum Lab is software to renders a visual sound spectrum only, not an audible one.

  2. With your scratch test nothing moves in the microphone volume indicator in Windows > Right-Click Speaker (lower right) > Recording devices though… (no greens)

  3. In Audacity,

— changing the sampling rate and format has no effect on the flatline either, so still no recordings.

— changing Stereo to Mono has no effect on the flatline, so still no recordings. However i notice the following difference in the volume indicators on top:
set to Mono, the mic volume bar bounces up only half as much as when set on Stereo
set to Mono, the speaker volume bar also bounces up (which it doesn’t do when set to Stereo)
When first setting it to stereo (no speaker volume bouncing) and then to mono (speaker volume bouncing) and then back to stereo, the speaker volume continues to bounce.

  1. Can’t see AISO in the diver management
  1. With your scratch test nothing moves in the microphone volume indicator in Windows > Right-Click Speaker (lower right) > Recording devices though… (no greens)

Right. So there’s something wrong with the way Windows is seeing your USB system.

in Spectrum Lab. So the microphone does pick up sound

Spectrum Lab is a program running on the same machine, right? I don’t understand how Spectrum Lab can be displaying sound without the Windows panels displaying it.

I’m getting seriously out of my depth. I don’t know enough about how to take apart Windows services. We should wait for a Windows elf.


Aha! …

I meanwhile did some more tests and figured out that the problem somehow is related to my TV tuner card. I had discovered that when I disable sound there (only there, not with the Windows volume slider), I no longer see the green sounds bouncing up in Audacity.

So, I thought I’d disable my TV tuner card and this did the trick.

I can now record sound with my microphone although oddly enough it still shows a flat line while recording. But when I listen to the recording, I have sound. The volume of the recording isn’t loud enough in spite of the UR12 pre-amp and even when using the win volume slider to max Audacity, but a big step ahead and almost there !

Many thanks for your help! Your lead helped me to figure it out!