Recording error is messing up stereo

I’m using Windows 7 and version 2.0.3

Whenever I try to record anything, audacity mixes the left and right sides together and records the same thing on each track, effectively giving me two versions of the same mono track. It’s really annoying and I don’t know what’s going on. I don’t really use audacity that much, just to record things from guitar pro so I can show my drummer new stuff that I’m writing. Does anybody know what could be going wrong?

How are you doing that?
I thought that Guitar Pro was able to export WAV files, so why do you need to record it?

Well, the way guitar pro exports .wavs is stupid and it always turns out glitchy and it sounds bad, so I like to do it with audacity. You can also monitor it with audacity. But if I ever need to record other stuff from my computer (I’m an animator, so I like to use sound bites from things) it still does the thing where it records both tracks on both sides and it’s really annoying.

So what settings are you using to record from Guitar Pro? In particular, the settings in the device toolbar and the Windows Sound Control Panel.

It’s not guitar pro’s fault, I know that, because I tried recording something off of youtube and it did the same thing. I just looked in the settings for my sound card’s stereo mix, and I went to the advanced tab and it shows that I have “1 channel, 16 bit, 44100 Hz (CD quality)” selected. I ASSUME that this is the problem right here, no? Now, if that’s the case, I have a few questions. Does that mean it’s basically running mono right now? And if so, then why can I still hear stereo stuff, just not record it? Also, what should the setting be? My sound card is a Realtek AC 97

Ok, I tried changing that option to something that was 2 channel, and it said that my device doesn’t support it. The settings in audacity are audio host: windows direct sound, output is just my speakers, whatever, input device: stereo mix (realtek AC 97 audio), input channels: 2. Now, in case this isn’t clear enough, I’ve always used audacity with these settings, but all of a sudden it decided to start mixing the two tracks into one, and then recording the same thing on either side. I’m still getting two tracks, like stereo is, but they’re both exactly the same thing. I can delete one of them and still have a perfectly good mono track. This sucks because the way I get guitar pro to sound descent is I have the rse guitars panned a little to each side and the way they mix like that sounds alright, but when they’re right on top of each other it sounds terrible, but that’s the way audacity wants to record it. I’ve done it where I just record each guitar separately and then mix them in audacity, but the drums are still mixed together, and I guess that’s ok, but it still bothers me. Is there some secret setting buried away in audacity that will fix this? Because everything says that it’s set up right, it just isn’t working right. Would uninstalling and reinstalling do anything?

Uninstalling and reinstalling Audacity would not help. Audacity is recording two channels but Windows is giving you a mono mix, which is what you have Windows set to (1 channel).

Basically if you see a message that stereo mix can’t record two channels, even at 44100 Hz 16-bit, then it’s broken. Try updating the sound device drivers ( ).

Or try Audacity 2.0.4 ( and record the computer playback using Windows WASAPI loopback. See the Manual ( ) for how to do that.