Recording echo of a muted track

I recorded drum beats on one track using my electronic keyboard connected thru USB to my laptop. Using these beats for reference, I recorded melody on other tracks. While exporting the audio to mp3 file I muted the first track with drum beats. Still during the playback, I hear a faint echo of the drumbeats. Surprisingly, the melody tracks (when played as solo) give out the drum beats echo even though visually it shows absolute flat lines in the quiet portions of the melody.
Even while playing the audio within the project (not mp3), I hear the faint echo of the drums when the drum track is muted, and the melody tracks show no visual indication of the beats. How to fix this?

absolute flat lines in the quiet portions of the melody.

That’s a display problem. The timeline blue waves only show you the loudest 25dB of the 90dB show. Quieter than -25dB or -30dB and the waves are flat even though there is still sound there.

This is normally good because most of the valuable show is in that loudest 25dB. You can change the timeline to be dB instead of percent. Right-click the vertical 1.0-0-1.0 bar > dB. That will show you everything, but it’s much harder to do detailed editing and production.

It’s not unusual for an overdubbed live performance to have the backing track leak in. Normally, it’s a setting and the backing track doubles in volume. No question what’s happening. Is the second performance voice? You can get a really quiet copy of the backing track through headphone leakage. Theatrical performances need large, gooshy headphones, not earbuds or other tiny earphones.