Recording does not record anything

Hello all ,

I have an issue with recording, I got it working when I just had this computer ( about a year ago) but it doesn’t want to record anymore, no clue what’s changed.

Here the setup:
Windows 7 (64 bit)
intel I5 with Asus P8H77-I (onboard sound).
audacity 2.0.5 (freshly installed)
(Playback sound is via HDMI to my amplifier)

I updated the drivers with the drivers from the onboard sound via the Asus-driver website : no luck

My goal is to record from a internet-radio station, I have read lots of stuff about sound mapper, stereo mix ,but I don’t see where I am going wrong , here some screenshots:



I hope someone sees the issue and knows the solution.

many thanks

“Stereo Mix” should record whatever is playing through the sound card.
Your sound card appears to be “VIA High Definition Audio”, so “Stereo Mix” should record whatever is playing through “VIA High Definition Audio”.
However, you say that you are playing through HDMI (not “VIA High Definition Audio”), so there is nothing for “Stereo Mix” to record.
To record playback sound, the playback must be through “VIA High Definition Audio” so that “Stereo Mix” for “VIA High Definition Audio” can record it.

I’m not on Windows, but apparently in the latest “Audacity 2.0.5” there is an option to set the “host” to “WASAPI”. This may provide a “loopback” recording device for the HDMI playback. As I said, I’m not on Windows so I don’t know if this is the case or not, but I think it’s worth checking. Audacity 2.0.5 is available here:

If that does not work, then you will need to configure your system so that playback is through the “VIA High Definition Audio”.

Hello Steve,

Thanks for your fast reply.

Still no joy however , but I kind of understand how it works now, and understand why it did not want to work the first time.

I first tried the wasapi:
These are the options I have:

If I understand correctly, the sound is produced by the “VIA high definition audio” that should be in the playback box, but which one , I got 4 options (RX-A830 is my amplifier by the way).
The recording device does not show the “stereo mix” anymore which one to select?

I have tried all settings I think , but , or I get a flat line when I record or an error message:

For the error message I read in another thread to change some settings for the queality , so I did , but still the same:

Than I tried the MME as host again:
Playback: with HD Audio HDMI out VIA high defintion
recording: Stereo mix VIA high definition

This gived me flat line.

I do not need to listen what I am recording, maybe that’s makes it a bit easier.
Any ideas?

Many thanks,

ps. sorry it is in dutch, I tried to install audacity in english , but it rec=verted back to dutch again.

You have a complicated set-up.
I’d suggest that while you are troubleshooting that you simplify the set-up. Once the problem is sorted out you can then add back the extras one at a time, checking that Audacity still works correctly (after a reboot each time).

So, the first thing I’d do is to disconnect the RX-A830, disconnect any web-cams or any other non-essential devices and strip it down to a minimal set-up of just the computer, monitor, mouse, keyboard and headphones (plugged into the on-board sound card). Can you get that to work? If so, we’ll try adding the extras back on and see when it breaks.

Hi Steve,

I disconnected the HDMI stuff plugged in a headphone on the line out and rebooted.

These are the options I have now:

I tried several settings , but with all I get a flat line when I press the record button (internetradio is running offcourse). Any option I should try and which should work?