Recording devices tab - gettign it to work[SOLVED]

Hi Folks,

My apologies as this is not a per se Audacity question but I can’t find a solution audio-wise and would greatly appreciate your help.

I’m testing screen recording software, a couple of which were suggested on this list (thank you very much!).

I installed all the audio drivers from the Toshiba site for my laptop.

But, when I go to test the mic to ascertain if it’s working by clicking on Hardware and Sound (in Control Panel) and then pressing the Recording devices tab I get that hour glass which remains on screen for hours and never opens anything to test the mic with.

In fact, on the bottom of that pop-up box the tabs for Configure, Set Default, Properties and Apply are all greyed out.

The screen then freezes so if I click the OK or Cancel buttons nothing happens.

To unfreeze the screen, I must access Task Manager and shut down Control Panel.

I’ve tried this several times and each time the screen freezes so I can’t test the mic.

I needed to test the mic to see why it’s not recording audio when I choose narration for any video screen recording I try.

I’m up to date with all my MS Windows 7 updates (including optional updates) as well as all my anti-badware.

All my other programs work well and the laptop shows no signs of any problems except this one.

I have plenty of RAM and hard drive space.

Any ideas of what I can try next are very much appreciated.

Thank you!

If sounds like Windows can’t access your audio recording devices.

Does clicking the Playback tab of Windows Sound also freeze?

What is the exact make and model number of the mic and are you connecting it to the mic port on the computer?

If you select a mic and press “Configure” on the Recording Devices tab, the choices are about setting the mic up for Speech Recognition including levels testing. Is that what you are looking for?

Even if you are sure you have the correct audio drivers from Toshiba you could always try reinstalling them. Driver installations can go wrong.

The other thing to consider is if some security software you have is blocking listing of the recording devices in an attempt to “keep you safe”, or conversely you could have a virus. When did you do your last deep virus check?

Also in the Windows Control Panel you can go to System and Security then look under “Security and Maintenance” for a link “Troubleshoot common computer problems”. Click that link then under “Hardware and Sound” there should be a link “Troubleshoot audio recording”. Try that.


Gale

Gale,

You are brilliant!

Running the Troubleshooting fixed it.

It now records but I’m hearing a kind of echo - like that Lou Gehrig speech where he says he’s the luckiest man alive.

Would you please share any thoughts about how I might address the “echo” effect?

Thank you so very, very much!

Best.

Please give us the make and model number of the mic and tell us how it connects to the computer. Or is it the internal mic of a laptop?

You may have to turn off microphone enhancements.

You won’t be able to hear yourself without echo while recording with an internal mic, and probably not with an external computer mic either. If hearing yourself live is the problem, turn off Transport > Software Playthrough near top left of Audacity.


Gale

The mic is part of a Monaural Headset with Microphone made by Altec Lansing.

I don’t see anywhere on the packaging a model # nor on the small, one page paper document inside but I do see on the plastic packaging in dark lettering AHS15 - maybe that’s the model #?

It’s an inexpensive headset but the mic works well on my desktop.

Thanks so very much.

Gale,

Following those instructions in the link you shared fixed it!

I clicked on the Enhancements tab where I disabled all “Sound Effects”

I then clicked the Playback tab in the main window of “Sound”, right-clicked over Speakers, chose Properties then clicked the Enhancements tab and disabled all “Sound Effects” there, too.

Now it sounds and looks clear as a bell.

Thank you so very much!

I hope you can enjoy a fun and safe July 4th.

My best to you.