Recording device [SOLVED]


I am using Audacity 2.0.6 on an Asus notebook running Windows 8.1

Have been happily using it for months recording drum tracks from a drum machine and bass guitar. I connect the instrument via a cable into a USB port.

Up to now I have had no problem but suddenly yesterday the USB recording device refuses to show in the recording devices section of the devices toolbar - only the internal microphone shows.

I have no idea why - I’m not aware that anything has changed. Everything’s fine another laptop running 2.0.5 and Windows 7 all is still in order - I can record with no difficulty.

Please help - I’ve tried everything I can think of and it’s driving me mad and the wife and dogs don’t like me very much at the moment because it’s making me grumpy.

There’s a hidden oddity in Audacity that it won’t auto scan for devices after it starts. So you can restart Audacity with the device plugged in or Transport > Rescan.


Hi Koz.

Yes - done that.

For some reason only the internal system mic shows.

Close Audacity. Can Windows find it? Search in the audio control panels. Win7 had little sound meters, so not only could you see the connection, but judge the sound volume, too.


Ah! Cant find anything other than the internal mic in Sounds/Recording devices on the Win 8.1 laptop but can on the Win 7 one. Why should that be?

OK - problem solved. I think the driver for the USB device had gone missing. Anyway I’m OK now. :smiley: