Recording device invalid when importing audio

I was going to record a cover of a song i like in audacity. Simple, right? Well, apparently not. I hit record and i got -9997 recording device sampling rate invalid. This was…Strange? I figured: “I’ll just restart audacity” Then I did. same problem. Mind you, these were after I had imported audio. So I did some testing and found out that…Yeah, its not broken the way I originally hoped. I can record normally without the audio file, but when I imported the file it decided to say its invalid. So I checked. help>diagnostics>audio device information.

NONE of my recording devices list supported sampling rates. Im extremely confused and i have no idea where to start so i need help.

This Audacity 2.4.2 running on Windows 10.

You’re overdubbing right? Recording your own voice over a backing track?

Just as a test. Forget the sound file for a bit. Press Record an make up a drum track with a pencil or a ruler. This will be track one.

Stop. Start recording your vocal. Did it fall apart and where?


So this indicated a different problem ENTIRELY. I can’t record anything to a second track. I make track one, good.
Second track is ****ed. invalid recording sampling rate yadda yadda yadda. Same error as last time. I re-tested a few times. No matter the device i use: Same issue. Is this a “reinstall and it should be fine” thing, or an incompatibility issue from windows/audacity that i either need to rollback or wait to be fixed if i dont wanna discard audacity completely?

So i fixed it entirely on a wisp of a whim. I absentmindedly swapped out the audio host which i noticed went from MME to WASAPI (Wasabi? xD) and so i switched it back, hoping for an error message that might give me more information. Nothing. It just…swapped. I was surprised so i tested it to see if it’d blow up in my face. Track one…Good. Track two…GOOD!!! OKAY. AM CONFUSION, BUT I AIN’T COMPLAINING. problem fixed…? I mean a private message explaining this nonsense would be a flippin godsend but otherwise, Thanks for the help but I guess i fixed it (knock on wood). Tysm!