Recording deleted as it records[SOLVED]

I am recording from a usb port.

When I first install Audacity play the audio and record audacity records the entire record;
after the record ends I stop audacity, It has recorded the entire record.
I can then edit the recording and every thing works fine.

if I put anouther record on Audacity starts recording and runs for 16 seconds then recording is deleted and recording starts again.
If I uninstall Audacity it works again for the first record then the same problem occurs.
I am using 2.05 on windows 7
I have not changed any settings that I know of.
Thanks for any help
Audacity output.jpg

So you mean you record 16 seconds, then while the next 16 seconds records, the previous 16 seconds is silenced? Or perhaps that the previous recording is silenced every 6 seconds, which is more understandable?

If so, Edit > Preferences, choose “Directories” and ensure you have permission to write to that temporary folder. Ensure the drive is working correctly. Do not use a network drive for Audacity’s temporary directory because it will be too slow.

If you believe the temporary folder has correct permissions and the drive is working OK, but the problem persists, please attach the log file from Help > Show Log… . Please see here for how to attach files: .


That Fixed the problem
I changed the temp file to one where I knew I had write permission and it worked