Recording cursor sticks when I use Audiobox USB

I have used a USB microphone successfully with Audacity in the past, so the following is a newly encountered problem. I have a new at4050 XLR mic that I want to use with an Audiobox USB interface (for which the driver software has been installed into my HP computer–Windows 8.1). When I try to record using “Audiobox” in the drop-down mic menu, the recording cursor will not move…nor will the cursor move when I try to listen to anything in the “Audiobox” output mode. (Voice activation is not on.) I am at my wits end with frustration. What is going on, and how do I get Audacity to allow me to record? Help!

Try WIN + X and Shut Down. Don’t use the Power button or Shut Down from the Charms Bar as that is not a full shut down.

If that does not help, choose 44100 Hz or 48000 Hz Project Rate bottom left of Audacity.

Try a different Audio Host in Audacity’s Device Toolbar.


Thank you so much, Gale, for your suggestions. I tried all three…none solved the problem.
The cursor still will not move when I use the “Audiobox” input and/or output settings.

The cursor will move (and Audacity will record) when using the other audio inputs (internal
mic and Blue Snowball), but that does not solve my issue…those are not the audio input mics
that I want to use. I want to use my new at4050 XLR mic with my PreSonus Audiobox USB
interface…and the cursor will not move on the “Audiobox” settings.

More suggestions are needed…from anyone, please.

You don’t give your Audacity version. Ensure you have 2.0.5 from .

What device is it - Presonus AudioBox? What is the exact model number? Has the AudioBox ever recorded? Does it have a control panel in Windows? If so, choose the same sample rate as the Audacity project rate. Do not choose ASIO drivers because Audacity as shipped does not support ASIO.

Connect to an empty USB port on the computer - not to a USB hub.

Change the USB cable.

Increase the Audio to buffer in Audacity’s Recording Preferences.

What host are you using in Device Toolbar ? Try another host.