Recording cursor lags behind waveform

Audacity 2.0.4 IIRC
Win Xp SP 2

I record for a local talking newspaper. We used to record using the PC’s internal sound card, but when it died recently I replaced it with an external USB sound card, the Creative E-MU 0404. We view recordings using the wave form display.

Previously, the red recording cursor was always at the head of the waveform. Now, however, the cursor lags behind the head of the waveform and gets further and further behind as time goes on. Because the display scrolls to keep the cursor in view, after a few tens of seconds the current recording is off the right-hand side of the screen and the technician can’t tell if he is setting the levels too low or too high. We have a number of readers and try to record in a single take. In between each story we insert a label using Ctrl-M to make separate audio files using File > Export Multiple… However, those labels now get placed somewhere in the middle of the previous story, i.e. at the lagged cursor position, not the real current recording point.

Do I need to adjust the latency setting or do something else? This is pretty much a showstopper.

Many thanks.

Run, do not walk, to update your Audacity to 2.0.5.


Thank you for your response, Koz. I checked the ReadMe sections
1.1 Bug fixes
1.2 Changes and Improvements
and did not see a fix for this issue. Could you give me the bug number?
Note that 2.0.5 has not been through our acceptance testing yet so we need assurance that it will fix the problem.
Thank you very much.

That’s a bit of a Catch 22, because we only officially support the current release version.
You should also be aware that Microsoft ended support for Windows XP SP 2 several years ago.

There is no guarantee that upgrading to Audacity 2.0.5 will fix your problem, but it does eliminate the possibility that the problem is caused by a bug that has since been fixed.

One option that is open to you is that you could go back to the old version of Audacity that you were previously using successfully, though of course you would then lose any new features and bug fixes that have been introduced since that release. Old versions are available here: Google Code Archive - Long-term storage for Google Code Project Hosting.
I don’t recommend this option, but at the same time there is probably no-one here that can offer support for Audacity on XP SP2 as the operating system is obsolete and there is probably no-one here using it.

We don’t have any developers working on old versions of Audacity. Bug fixes and new features are aimed at improving the current version to make the next version better.

You could try adjusting the buffer setting (Edit > Preferences > Recording). The default value is 100. Some users achieve better performance by changing this to a higher or lower number. If you set it too large or too small, recording may stop altogether, so try changing it a small amount at a time to see if it gets better or worse.

There are also some tips here for improving recording/playback performance.

Did the issue appear after you upgraded from a previous Audacity version to 2.0.4, or after you changed to the E-MU? If the latter, then you should look at any E-MU buffer settings as well as those in Audacity.

What host are you using in Audacity Device Toolbar? MME is most compatible.

I suggest you quit 2.0.4, get the zip of 2.0.5 and try it. That way, you don’t have to install it.

What you describe is not a known Audacity bug. You should update to Windows XP SP3 then make sure you have the correct drivers for the E-MU.


Thanks all for your suggestions.

I am actually on 2.0.3 and have now upgraded XP to SP3 (which was on the list to do but didn’t get time earlier). The problem only arose from when I installed the external sound card, and I made no other changes at the time.

The problem appeared to be intermittent but I think I have found the cause. I set the sample rate in the E-MU 0404 Control Panel to 48000 and set the same in Audacity preferences, but loaded a project that had been created with a sample rate of 44.1K and added to it with Append Record. Audacity must have taken the project rate rather than the one set in Preferences – confusing to me! So my guess is that Audacity was updating the recording cursor at 44.1K while the numbers were coming from the box at 48K. At any rate, I can’t reproduce the problem now I have set all the rates to 44.1K.

I’m glad it seems to be fixed.

Typically having “mismatched” sample rates between Audacity, Windows (if sample rates can be set) and an external device can cause audibly incorrect speed, synchronisation problems between tracks and/or crackly quality.

Yes if the project gets set to some rate other than the Default Sample Rate in the Quality Preferences, the recording will be made at the current project rate so Audacity might resample from the rate the device is sending. If you opened a fresh project at 48000 Hz then imported a file that had a sample rate of 44100 Hz, the project rate would also change to 44100 Hz.

Generally, the recording cursor does not get behind or in front if the project rate and device rate are different.

However now you say that you were Append Recording, I see there is an issue with Append Record if you append and the project rate is different to the track rate. This is reproducible for me on Windows 7 x64 in 2.0.6-alpha and 2.0.0.

  1. Default Sample Rate 44100 Hz, open a fresh project.
  2. Record a few seconds and stop.
  3. Change Project Rate to 88200 Hz and Append Record.
  4. Recording Cursor lags behind and on playback, the recording is double the correct length and half speed.
  5. Change Project Rate to 22050 Hz and Append Record.
  6. Recording Cursor advances ahead of the recording, and on playback, the recording is half the correct length and double speed.

I guess this is obvious really, but I don’t know if it’s fixable.

Were your track and project rates mismatched, arowland?

Does the record cursor lag behind if you create a new project at 48000 Hz, change the project rate to 44100 Hz then record (that is, not an append recording)?