Recording cursor acts stuck - latency error message

I’m using Audacity 2.0.5 on Windows 7 (Home Premium, if that matters). I used the .exe installer. My recording setup has worked fine in the past and is connected properly. (I’m using two MXL mics connected by a Focusrite brand … Magic Box that Talks to My Computer by USB.)

When I press Record, a new track is created as usual, but the cursor twitches as if it is trying to move but is stuck at t=0. Nothing is recorded. If I press the play button, it doesn’t stay “depressed” because there’s nothing to play.

If I record two tracks in a row (by pressing Record, Stop, Record, and Stop), I get the error message described on this page: http://sourceforge.net/p/audacity/mailman/message/31936456/
It says:

“Latency Correction setting has caused the recorded audio to be hidden before zero. Audacity has brought it back to start at zero. You may have to use the Time Shift Tool (<—> or F5) to drag the track to the right place.”

I have tried using the time shift tool (There is nothing for it to select), restarting my computer, uninstalling and reinstalling Audacity and checking the box to reset my settings, fiddling with the latency settings in the preferences, and using the timed recording option. I’ve checked the FAQ and the first few pages of this forum. The problem remains.

Playing my old audacity projects works fine. It’s just recording that isn’t working. If you have any ideas, let me know!

What settings are available in the device toolbar and which are selected?

AudioHost - MME (As opposed to Windows DirectSound or Windows WASAPI)

Output device: Speakers and Headphones (a no-brainer)

Input device: Scarlett Line-in (also definitely the correct thing)

Input Channels: 2 (one per speaker)

Oh, and it’s suddenly working. …Maybe it’s because I unplugged the USB cable and the driver reinstalled when I plugged it back in? And I put the speakers away, of course. :frowning:

Well, thanks for asking. If you have any guess as to why it started working, please let me know.

No idea, but if it happens again the thing to try:

  1. “Safely Remove Hardware” and physically disconnect the Scarlett. If the Scarlett has a separate power supply, unplug it or switch it off.
  2. Reconnect the Scarlett and wait for Windows to find it.
  3. If Audacity is open either close and restart, or (easier) select “Transport menu > Rescan Audio Devices”.

Okay. Thank you!