Recording bugged after Microsoft update

Hi, I have been recording for years using audacity to record a sax lead over pre-recorded backing tracks with no problems whatsoever, and with great results.
I have used, and have continued to use, a Focusrite Scartett sound card/audio interface with Scarlett Studio mic CM25.
Recently there have been a few changes that were more or less date coincident: 1) I had 2 major Microsoft updates, 2) I changed from Audacity 2.1.0 to 2.2.2 and 3) I now have a new ASUS Sound Master laptop computer name: DESKTOP-H6B5RAD Model X541NA, 64 bit system with windows 10.
When I download the backing track and then attempt to record, the curser continues and the recording occurs along the same track but from the tail end of the downloaded backing track. If I open a new track and then attempt to record, I get the message: “ERROR OPENING SOUND DEVICE. TRY CHANGING THE AUDIO HOST, RECORDING DEVICE AND PROJECT SAMPLE RATE.”
I normally use MME so tried both of the Windows hosts but bot produced error messages similar to the above.
The recording device was displayed as “Line in 2 Scarlett” and “Line out Scarlett 2” plus the Scarlett has been checked out by the local sound experts and declared in god working order.
I have always used the sample rate of 44100 so tried many other but with the same error message.
Playback of earlier recordings through the Scarlett is fine. Recording is fine except on the wrong track.
Any advice on how to handle this from anyone out there would be very much appreciated.
Mister Saxophone

the Scarlett has been checked out by the local sound experts and declared in god working order.

The Solo is good, but maybe not that good.

I’m not a Windows elf, but it’s fairly common for a Windows update to kill some devices as a, usually correct, security move.

Audacity will not record anything that Windows isn’t OK with, so that’s where to look.

Like you, I expect what you’re doing to work perfectly. That, in general, is one of the recommended microphone configurations.

the recording occurs along the same track

That’s a setting now. Shift-R and R have been reversed. You can do that manually, or you can change it back permanently through a preset. I need to leave now.


This is due to a change Microsoft made to Windows’ Privacy settings. see here:

Actually my mic is recording well and has not been turned off. The problem is that when I try to record, no new track is opened and the recording occurs as a continuation of the same the track as the already downloaded backing track. I need to handle this urgently but have not been able to find a fix.

I presume that your last post means that the problem is resolved. Is that correct?

Unfortunately not. The unresolved problem is that when I attempt to record, the recording occurs in the same track after the end of the already downloaded backing. If the newer audacity software required that I open a new track manually, that would explain things but I have not been able to locate any reference to this. Id=s this the way it is on Audacity 2.2.2? Sorry for all this but I need to get back into recording and I am relying on you for help in this.

Yes we changed this behavior, flipping the two record modes - you can either

a) use Shift + Record or shortcut Shift + R to record on a new track below, based on the cursor or selection position.

b) revert to the old behavior where plain Record records on a new track (and shift modified records at the track end) by setting the Preference for Always record on a new track in Recording preferences.
See this page in the Manual:

We changed this for the 2.2.0 release see- the archived “What’s new” for that release:


Thanks! Sorry about all of the back and forth but I have got it now. Your help is very much appreciated. I am happy and back in action.