Recording album at max but no clips

I recorded songs and red clipping marks showed when rec sound went over 1.0 on waveform graph and also when at or over 0dB rec level. Now with replaced turntable when I record same songs at max levels red clip marks never show.

You’re complaining because it’s NOT clipping?

Are you recording the exact same record? Different records have different volumes/peaks.

Or, the cartridge may be slightly less sensitive (this is analog and there are variations) or maybe there was a small design change and you’ve got a different revision of the same product.

I don’t believe I have used ‘hard limiter’, unless it’s use is hidden.

The effects in Audacity don’t run in real-time while recording. You have to record first, and then apply the effects to the digital file.

…and run Analyze ‘Find Clipping’ show no red marks.

Another “trick” for checking your peak levels is to run the Amplify effect. Amplify will scan the file and default to whatever change is required for 0dB peaks. You don’t have to apply the Amplify effect… You can cancel after checking the peaks if you wish. For example, if it defaults to +1dB, your current peaks are -1dB. If it defaults to 0dB change, your peaks are already at 0dB and you probably have clipping (if you have just recorded, and not already adjusted for 0dB peaks).

Since the analog level is unpredictable, it’s best to shoot for peaks somewhere around -6 to -3dB, leaving a little headroom. Then you can “normalize” for 0dB peaks after recording. If you ever used an analog tape recorder, you may be used to occasionally going “into the red”. Tape starts saturating, usually around 0dB, and progressively gets worse, so it tends to “soft clip”. But, digital just hits a hard limit and goes no farther so you get hard-clipping and you simply cannot go over 0dB.*

my first post anywhere [usually figure things out].
68 yrs old so be easy.

Your post would be easier to read if you break your thoughts into paragraphs. :wink:


  • Your analog-to-digital converter, digital-to-analog converter, CDs, and regular 16-bit or 24-bit WAV files are all limited to 0dB and they will clip. However, Audacity itself uses floating-point so there is no upper limit and it can go over 0dB without clipping.

Sometimes extreme peaks can occur due to clicks/pops on the record (scratches cat-hairs etc.).

When transcribing my LPs my first step after capture was to export a 32-bit WAV and process that through Brian Davies’ ClickRepair and then reimport that back into Audacity for further processing - see this sticky thread:

I would suggest though trying Audacity’s latest click removal provided by Paul L (not available when I was converting my LPs) - see this thread:
I think you will need to use the alpha test version of Audacity for this until the next release of Audacity - see:


Why? DeClicker is not a version 4 plugin, which would require the next 2.1.0 version of Audacity.


Ooh - I didn’t realize it was available for current Audacity :blush:

Thanks to everyone for the replys. Yes my 10th grade English teacher taught me about paragraphs, so thanks for the reminder. Great to have so many dedicated, knowledgeable people willing to help a newbie.

I don’t have a problem with clicks or their removal. It’s really not clipping that I have the issue. It’s getting the red lines/marks to show when do have clipping. That is why I intentually recorded album/song at max 100 volume level. I wanted the red lines to be seen. Have yet to see red clip lines no matter what I try. I normally keep my recording about 65 level and keep the meter between -3 and -6dB. I will have a couple clips above -0s, either fix them or ignore. If I have too many I redo at lower level. No problem with this. I find it much easier to find the clipping if the red lines are present, especially in reviewing an entire recorded album.

The first turntable I had to send back a couple weeks ago showed the clipping red lines, no problem. Now with replaced same brand turntable no red clip lines, same album, same connections, same settings. That’s is why I said previously on new TT now, even recording at max levels ie 100 on mixer bar and max on vue rec meter I can not get red clip lines to show on waveform graph. I have ‘show clipping’ enabled and after recording under Analyze, I run ‘find clipping’ at default settings. I have reduced ‘find clipping’ settings with no change.

Possibly the statement by DVDdoug ‘Audacity itself uses floating-point so there is no upper limit and it can go over 0dB without clipping.’ has something to do with my issue. If Audacity does not recognize clipping over 0dB then it wouldn’t show red lines. This is a little confusing to me.

I just want to be able to find clipping without pouring over long blue line waveform graphs. Can’t see how using 'Amplify" would help in highlighting clipping. Again I am a newbie here. And yes, I will in future use USB recording connection. Want to know what I am doing wrong with Audacity and be able to find clips easier. When I see them I can control them. Red lines makes them easier to locate.

Thanks again for all help. By next post I will have learned to properly ‘Quote’ and ‘highlight’. Don

In the tutorials we recommend aiming for a maximum recording level of -6dB which corresponds roughly to 50% on the linear waveform display. That is is plenty strong enough signal to record and work with - you can amplify it up if requires as one of the final stages in your editing process.

Part of the problem, I always think, is that folk look at a waveform peaking at 50% and think “aw that’s not a good enough level” when it really is - they want to fill the waveform window - look at all the various tutorials that folk post on t’interweb where all the time you see oversaturated signals. I started out that way too when I was transcribing my LPs until I learnt better …

We are changing the meters in the upcoming 2.1.0 offering a graduated colour meter to assist with avoiding oversaturation:
You can already help yourself by making the meters larger by clicking and dragging the bars at the right of the meter toolbar (I had mine stretched across the whole width of the Audacity window).

Also in 2.1.0 the meters will be separated so you can resize the recording meter only if you wish - this has enabled me to have an even wider recording meter with a relatively small playback meter.


It is good if you do not have clipping.

There is no direct relationship between the recording level slider in Audacity and the level you record at. It depends on the strength of the signal too. If you are playing a quiet song it may never clip even at maximum recording level.

Show Clipping redlines as soon as there is a single audio sample very close to 0.0 dB. To prove that, Generate > Tone at Amplitude 1.0 (linear). That actually produces peaks a little below 0.0 dB, but the peaks should all redline in Show Clipping. You can use Analyze > Sample Data Export… and export a file to show that the peaks that are redlined are not quite at 0.0 dB, but probably at -0.00010 dB or similar.

No. Show Clipping still redlines audio “touching” or above 0 dB even when the audio is represented in 32-bit float format (as shown at far left of the blue waves).

Select all the tone you generated above, then Effect > Amplify… and enter 2.0 in “Amplification (dB)”. Check the box to allow clipping then OK. You will still see the red lines. But because this is 32-bit float, the curved tops and bottoms of the waveform will still be represented rather than being cut off, even though they are above 0 dB (+1 /-1 linear).

To prove that, zoom in , then hover over the vertical scale immediately to left of the waves. When the mouse pointer changes to magnifying glass, right-click to zoom out the scale. Now you can see the round peaks perfectly preserved, but red lined.


If Audacity is set to a project rate of 44100, I found out that my Sound Blaster card actually captures at 48k and internally converts to 44.1. In so doing, the clips have been converted to a value less than Audacity would display with red bars. Changing to 48000 project (capture) fixed my problem.

It is often helpful to set the Audacity project rate to a rate supported by your sound device.

Resampling properly done should not change the peak amplitude of the waveform.


I’m not resampling when I encounter the problem. My projects were set up to capture at 14.1 thinking that if I’m going to burn CD’s I should uses the same rate and that it would result in smaller file size. The SB card’s ADC evidently is locked to it’s highest sampling rate but then internally, SB converts its output to the requested value such as 14100. No user controls are available to internally control ADC rate. Little do you know that the card is buzzing along at its highest rate, internally converting to the requested sample rate, and passing along rounding errors that may have occured. Perhaps they intentionally round to prevent divide by zero. The rounding is downward resulting in a clipped value of less than a linear maximum +/-1.000.

Here is data of a wave form clipped 10 times, Audacity doesn’t redline it. The first two and last two samples are not part of the flat ;

sample-data5.txt 1 channel (mono)
Sample Rate: 44100 Hz. Sample values on linear scale.
Length processed: 14 samples 0.00032 seconds.

Maybe someone with more knowledge can explain and or verify this anomaly with SB and possibly other cards and formulate an FAQ response. I wasn’t able to solve this problem until I searched SB and other places on the web.


Presumably 14.1 and 14100 are typos for 44.1 kHz and 44100 Hz?


But you are saying SoundBlaster is resampling, correct?

Where does that waveform come from and what are the original values? Are you trying to record a full-scale or clipped tone playing in Audacity?

It’s not a “frequently” asked question, and not an Audacity problem if I understand you, though it’s interesting if true.

What bit-depth are you recording at? What version of Windows are you using? What version of Audacity are you using? What host are you choosing in Audacity’s Device Toolbar? You may be able to set SoundBlaster in Windows Sound to use 44100 Hz Default Format (on Windows Vista and later).

Please post the online references you found as to why SoundBlaster adjusts sample values down when resampling or when using higher sample rates.


Thanks Gale,
Sorry about the typo. Yes I meant 44,100 and not the old telephone modem rate reference). For newbies, 44,100 hz (hertz or samples per second) is the same as 44.1 khz (kilo-hertz).
Originally I thought setting a capture rate of 44,100 and depth of 16 bits might be best since this is standard wave format of audio CD’s and is the final destination of my music. At that rate I had a bad result of the red line clipping indicators didn’t show. I have since read that the software in windows actually does math and transformations quicker and more accurately in the 32-bit floating point rate. Probably due to the onboard math coprocessor. So, my preferences are to set my projects at 48000 capture rate and a bit-depth of 32-bit rate. I’m guessing this costs in file size.

My other settings;
Audio host: Windows DirectSound
Output decic: SB Live!
Input device: SB Live! - Line In

On my computers with SoundBlaster cards I’m running Windows XP with all updates for windows as well as the latest updated drivers from Creative SoundBlaster for the card.
You suggested “You may be able to set SoundBlaster in Windows Sound to use 44100 Hz Default Format (on Windows Vista and later).” That isn’t the problem because the sound card does allow it’s output to be configured to deliver 44,100/16 bit output to Windows and the Audacity application. But, and I was unable to find any direct reference from Creative, the card actually samples at a higher rate and internally does the conversions with round down errors.

A suggestion to the Audacity development team is to allow the red-line clipping point to be configurable to a value to compensate for in-line hard and soft clipping points.

I will continue to look for a knowledgable reference to the SoundBlaster condition.

Thanks, Rusty

I’ve only skimmed this topic, but that sounds like the old EMU10K1 / EMU10K2 chips. They were very popular for mid-range Creative sound cards for many years (I’ve still got a couple of old AWE 32 cards somewhere). The same chips were used in more expensive EMU sound cards. Internally they run at 48 kHz and include on-board DSP (digital signal processing) which is best avoided if you want to do straight recording / playback (but very useful if your interested in sound synthesis).

The drivers for those cards were something of a let-down, but for anyone with > 80% geek rating there were alternative drivers available from the KxProject (

As you describe, one common quirk was that they clipped below 0 dB. It was possible to avoid that by carefully tweaking the settings (some of which are hard to find). If I remember correctly, the optimum settings on the AWE 32 was to set all levels at 72 %.

Another quirk of several in that range (including the AWE 32) was that the rear line output was higher fidelity than the front line outputs (the Kx drivers swapped the front and rear outputs so that the “main” outputs were from the rear output socket (so as to take advantage of the better sound quality).

There’s a fair bit of technical information on the KxProject website (better to read it than rely on my memory - this is going a long way back in history) :wink:

32-bit float is the default for Audacity and recommended. Yes 48000 Hz project rate takes about 9% more disk space than 44100 Hz.

Please see Important information for Windows XP users. for more information about Windows XP and Audacity.

OK we’ll count that as a “vote” for that enhancement.


Was that tweak possible without using the Kx drivers, do you recall?


Setting levels for undistorted recordings producing a 0 dB waveform was possible with standard drivers, provided that the audio source did not overload the soundcard inputs. I believe that was the case even after I upgraded to Win XP (from Win 98).

Some followup of my previous post; the article at Wikipedia on the SoundBlaster Live!! does a good job of explaining the shortfalls of the EMU10K1 chip used in this and other SB cards. It notes the DSP internal sampling rate is fixed at 48000 and that the card has audible problems in the rate-conversion step which can be overcome by converting as a seperate process (i.e. capture at 48000 and allow Audacity to export the results to other rates such as 44100 for burning to CD).
I have looked for the third-party drivers at Kxproject ( but run into a “502 Bad Gateway” error when clicking on the filename. Anyone have any suggestions?
Many thanks for the feedback,

Note that those drivers are a lot more complex to use than the normal “consumer” drivers provided by Creative.
The 502 error may just be a temporary error, but if the problem persists you could try getting the drivers via the Wavbackmachine website:

I found an old barebones article about Sound Blaster on Audacity Wiki, so I updated it with some of the information in this topic: