Recording a second track...

importing an MP3 of the music track and trying to record a separate vocal track. When done, however, the music is showing up on the vocal track? Am I missing a setting or something? Thanks in advance.


Which version of Windows?
Which version of Audacity? (look in “Help > About Audacity”)
What sort of mic?
How is the mic connected to your computer?
Which recording device have you selected in the device toolbar?

Your sound card mixes out stream with in stream… you should search for a button to turn off the mixer on the sound card.

Selected USB/Line
Here’s a pic of the Behringer mixer, with the Behringer interface connected.

If you hear the first track when recording the new track, then that first track will be recorded onto your new track.

One way around this is to use a headset to listen to the first track while you record the new track.
I’ve gone as far as playing the first track in a non-Audacity media player and listen on my headset while recording the new track. Once finished, I import the first track into audacity so I have both the first and new tracks in separate tracks with no bleed over. That allows detailed balancing between the two to create the final track. There may be some slight “latency” issues between the two tracks, depending on your setup, but you can offset the first track from the second to compensate.

It is possible in the Audacity “Preferences”, to un-click the two play through options so the first track is not heard while recording, but that sort of defeats the purpose since you can’t hear the first track.

Hi there,

I am a new user of Audacity and Windows 11 and will be using my setup for creating multi-track music recordings.
I am using a Behringer UCA222 audio interface to connect my laptop to my Alto ZMX52 mixer, using the AUX connections on the mixer.
When playing back separate tracks by using the Audacity ‘SOLO’ button, I could still hear audio from other tracks bleeding through.
De-selecting the ’ TO MIX ’ button in the AUX section on the mixer does indeed fix the problem for me - this suggestion was mentioned by someone else in this thread. Other mixers should hopefully offer a similar control.