Record stereo playback from 5.1 sound card [SOLVED]


with 2.0.5 I recorded the OS sounds (live from YT).
where are they located?
I dont find the folder. thanks.

Vista32 sp2

Did you Export a sound file when you got finished recording? If you did, it will ask you where you want to put the file. I put work like that on my desktop until I figure out where I want to put it during or after production.

If all you did was Save the Project, Audacity may have tried to put the show in with your other applications. I’m not a Windows elf, but I know that can cause problems.


Hi, thanks for your reply, much appreciated.

No, I just stopped the recording, I did nothing else.
Perhaps the recorded file has not been saved?

thanks. Best,

I exported now.
but why the results are very bad?
low volume and effect as I were in a central station (astonished)
why I dont hear a clean sound?

Until you save an Audacity project or export, the audio data is in Audacity’s temporary folder. Edit > Preferences… then look in “Directories” to see where that folder is.

Are you sure you are recording properly and not with the internal microphone? You need to choose a special input in Audacity’s Device Toolbar that is meant for recording computer playback. Have a look at Tutorial - Recording Computer Playback on Windows - Audacity Manual. Also, turn off Software Playthrough in the Transport Menu at the top of Audacity and turn off sound enhancements and effects in your sound card control panel.

Using the Windows WASAPI method of recording computer playback is simplest because you don’t have to rely on your sound card having a special input for recording of computer playback. See the Tutorial above for how to use WASAPI in Audacity.

If “YT” means YouTube, you can download the videos if you search online how to do that. And if you install FFmpeg you can drag that video into Audacity and it will extract the video’s audio for you. At that point you have not lost any audio quality and you have made sure that you won’t also record system dings and beeps.

Of course, we assume you have copyright holders’ permission to download or record the videos.


Ooh that’s very interesting, I never knew that - must try this sometime.

(this is me writing this down).


Hi, thank you for your reply.

Even if I will use the recording option for silverlight on a webpage, just for testing I tried recordign from a file in my pc via VLC player.
Here my Settings (I hear all the OS audios via usb headphones):

clik Record, then Stop, then Export audio > mp3> save…

…and I go a mp3 file empty! (only 1kb).

what may be the error?


Hello dear friends,

the problem seems resolved choosing the following settings:

the audio is good now!
only a doubt:

before exporting the file as mp3, I become a warning message : “the audio tracks will be united into a single track”,

and the result is a mp3 file MONO, not stereo.
If you have suggestions how to obtain real stereo I 'd be very grateful to you.

thanks, Best
PS: Software Playthrough was already unchecked.

if I force 2 channels instead of 6, I go thid error and nothing done:

it were super if I could to obtain the file with the setting above, but stereo and not mono. thanks. best regards.

Yes, in Device Toolbar, it would be simplest to set Recording Channels to “2 (Stereo)”. You seem to be recording six mono channels, four channels silent. You might be able to change settings in Windows so you can record stereo in Audacity, but If you can play 5:1 surround sound audio through that sound card in other Windows applications, I would not change the Windows setting.

Instead, click the downwards-pointing arrow in the first of the tracks that has audio, and choose “Make Stereo Track”. Then click the button on the four silent tracks to close them. Then you can export as stereo. The two mono tracks you recorded seem to have different signals in each so it should be fine when made into stereo.


Hi Gale,

it works fine now! thanks a lot!
a very good suggestion.

I have to set 6 channels because the audio output is “Headphones Trust sourround 5.1” (even if the file to be played is not ac3 dd 5.1). Therefore Audacity sees the file as having 6ch with 4 empty channles.
I deleted the empty channels as you suggested.
Now I have a very good stereo mp3!

I noticed that it is better to set VLC at 100% volume before recording.
Then, when I hear the exported mp3, with the headphones, I set VLC to 36-40%.

(Tomorrow I will try the same task, not with vlc, but with a web streaming through silverlight).

I warmly thank you, you helped me very well.