Record/save tracks alignment issue

I have windows 7 & audacity 2.0.5
I record and save a variety of tracks as mp3 files then when import them to save as a single, say 4 track file, the tracks do not play in alignment,(too fast or slow to each other)
This never happened before I went to Aud 2.0.5. I’m sure it is just a click of something but I cant figure it out.
Any help is appreciated

The current version of Audacity is 2.1.1 and is available here:

Are you sure they are playing at the wrong speed and not just starting at slightly different times?
When moving files around it is better to use WAV format as MP3 loses some audio quality and adds a little bit of silence to the beginning of the file.

Thanks Steve…Yes the speed is different. I tried to shift the start times but it was still off register

Very odd. Can you reproduce the issue in a new project? If so, can you give me step by step instructions for how I can reproduce the problem?

I’ll try to do another project and see how it comes out. I’ve been backtracking my steps and one that I’m not sure of, is when I highlight a single track for editing effects etc, it sometimes highlights all the tracks that I have open or the reverse when I highlight all the tracks it sometimes defaults to one track and doesn’t apply the effects them all.
I’ll keep trying and get back to you if I’m still stymed.
Thanks again, PS: I’ve downloaded 2.1.1 and I’ll use wave for files & see how that works.

Do these links help?

How do I select audio in one track?

How do I extend or move the selected region into other tracks?

Audacity Selection


Hi again
I did another quick project:

  • Recorded a guitar track #1. edited: amplify, bass treble, normalize, reverb, saved as mp3 & wav 32 bit
  • While listening to track #1, I recorded a vocal track #2 (both tracks on same screen) edited it with the same effects as track #1, saved track #2 as mp3 & wav 32 bit.
  • Closed the files, the reopened track #1. I then imported, track #2 as audio.
  • Played them together. Track #2 seemed to start at the right time but was slower speed than #1
  • I had track align clicked at sync lock. Note other times I’ve had this problem the track align was not used.
    I’m baffled, hope you can help.

Did you play the tracks before exporting, and did you hear the same problem then?

Speed drift can happen if you use different sound devices for recording and playback and the devices’ clock speeds do not match.

Or you are recording where project rate bottom left is different to the sample rate of the tracks.

Or the drivers of your sound device are outdated or inappropriate.

Or your recording has lots of dropouts which make it short. Solo the recorded track. Does it sound like it has dropouts?

Please click this link for more help:


Hi Gale
Thanks for the hints.
The tracks play fine separately after recording and editing, and they all play together fine as a group before saving, but when you save the tracks separately then import them to do more editing or to create a master, they are all at different speeds. However, If I save all the tracks together as a master rather than separately, they work fine. Seems like there’s something in the individual saving process.
I never had this problem before with the previous versions of Audacity, and I have done a lot of CD’s over the 10 years I’'ve used the program.
Is there something I should check on the menue bar like tracks alignment or other settings that might not be correct ? Something that I may have accidentally clicked on or off /
Appreciate your patience and help.

How are you exporting separately? File > Export Multiple… or selecting a track, File > Export Selected Audio… then repeating that for all the tracks?

When you import the exported files, do the tracks start at time zero, or does their audio start where you expect it to? And are the tracks the expected length? If the answer to both those questions is yes, then by far the most likely explanation is that your sound card is faulty. Perhaps it has had a bad driver update through Windows Update that you need to roll back in Device Manager.

Does that mean saving an Audacity project, or File > Export which mixes the tracks together, or both?

The new Audacity 2.1.2 is available now: In case this is an Audacity bug, please try with that.

If you still get the same problem could you post a screenshot of the Audacity project before you export separate tracks. It may be best to do View > Fit Vertically and View > Fit in Window before taking the screenshot. Please see here for how to attach files:


Hi all

Thanks to the Audacity team for fabulous software. I have a similar problem…I think (reason for replying and not starting a new post).

I have Ver 2.1.2 on a Windows 10 PC 64-bit; I am recording by ‘listening’ to the input of the sound card. I can see that the recording is being laid down too slowly - the second markers click by at almost exactly 2 second markers for every 3 real seconds. As a result, the playback sounds too fast.

I’ve aligned all the sound card variables to 48000Hz and Studio Quality 24-bit. The playback speed is 1.0

I don’t think it’s something I’ve done as I’ve only just reinstalled Audacity after the Windows 10 upgrade. As far as I can see everything is default setting and it used to work before.

I should be grateful for any suggestions.



It is almost always best to start a new topic. You are on a different operating system to the other user, almost certainly have different hardware, your specific symptoms are not identical, and if the other user replies then we have to converse with multiple users in the same topic, which can get very confusing.

Did you try everything here: ?

Reinstalling Audacity does not reset its settings unless you enable “Reset Preferences” half way through the installer.

48000 Hz is a common sample rate but 44100 Hz is safer and is sufficient to capture all sounds that humans can hear.

We can’t help further without some more information to go on.

Exactly what you are recording? YouTube? Game play…?

What is the make and model number of the sound card? If you installed Windows 10 on the same hardware, then because it is a different operating system it may require updated drivers for the sound card. See

Exactly what do you have set for Recording Device and Playback Device in Device Toolbar? There are different ways of recording computer playback.

Are you recording while playing back existing tracks in Audacity?


Thanks Gale

I will start a new post, answer your questions there and put the link on this thread.