Record/Playback Meters Don't Always Work

I’ve been using Audacity for a few years on my Mac (Big Sur and previous). Never had this issue before with two other hardware interfaces.

However, just bought a MOTU M2, and now when I record or playback, the level meter sometimes works and sometimes doesn’t. Sometimes it doesn’t work, but then when I save the recording, close Audacity, and then re-open both it will work fine… but sometimes not!

It seems to happen more when I record in mono than stereo, but that’s not 100% consistent. Any thoughts? I’m using Audacity 2.4.2.

Does this happen if you select the Mac’s built-in microphone and built-in speakers/headphone jack?
– Bill

I just tried, and the meter worked fine on one channel.

I just tried this, and the meters work fine.

The problem seems to be when recording and listening to playback through the MOTO M2: the meters on Audacity don’t work. Once I save a recording, re-open it, and switch playback to go through my speakers or headphones plugged into my computer, the levels meters work fine.

The obvious downside to this is that I can’t see my levels on Audacity while recording; OTOH, the MOTU has level meters on it that do respond during recording, so as long as they stay out of the red I’m okay.