Record On My Laptop Not Working


I am wondering if someone could provide me with some basic standard setup options that I can enter into the Preferences section of Audacity. My attempt to record is resulting in a very low-volume sound that is mostly sputtering — kind of garbaggy. On the Playback there is almost no recognition of the music I try to record. I am basically a novice when it comes to knowing what a reasonable ‘setup’ should be in music terms, so please forgive me if my questions seem a bit dumb. I did try to read the Help area and make some changes in Preferences, but now I am feeling confused.

My version of Audacity is 2.0.5, and I am using Vista Home edition of Windows. It is possible that my laptop is the problem (I think), but I am not sure. I hope I can still make some decent simple recordings.

Thanks to all,


Hi Joe. What are you trying to record, for example: “I’m trying to record from an Ion USB turntable, model “Profile LP” which is connected via a USB hub to my laptop”.
(by the way, recording via a shared USB hub is not recommended).
Perhaps you could post a short audio sample to demonstrate the problem. Just a couple of seconds in WAV format will help. (instruction here:

Hi Steve,

First of all thank you very much for the fast reply.

(1) I am trying a simple ‘record’ of a song I found on the Grooveshark music website. I start up Audacity, press ‘Record’, and play the song (Don Henley’s “Sunset Grill”). As a test, I let the song run for about 30 secs - 1 min, and then press ‘Stop’ in Audacity. I then ‘Play’ in Audacity, which is where I get the bad result.

(2) I will be happy to provide a sample of my result for you. I assume I save the file in Audacity in ‘WAV’ format, is that correct? After I save it, how do I provide it to you? Do I attach it here as part of my next reply to you?

Again, many thanks Steve.


[u]This page[/u] tells you how to record streaming audio.

Streaming audio is generally more compressed (lower bitrate & lower quality) than downloads from Amazon or iTunes, but when you record it, the recording shouldn’t sound much worse than when you listen to it in real-time.


Thanks for the comments. I will read the info shown in the link you provided. And I feel encouraged by the thought that a recording I make shouldn’t sound too bad in the end.


I saved the sample I recorded into a WAV format file. Should I attach it in this area? Do I use the Upload attachment tab?

Thanks to both of you.


Yes, upload it here. Instructions here:

OK Steve.

Will it be useful to attach a screen print of my Audacity starting screen in addition to the WAV file?


Hi Steve,

I hope this works OK. I am attaching the WAV file and a screen print of my starter screen in Audacity.

ScreenHunter_18 Dec. 04 01.12.jpg


I only saw the screen print get attached, so, just in case, here is the WAV file.


Looking at your screen capture, I can see that you’re trying to record streaming audio through your microphone, which might not even be plugged into your laptop! No wonder nothing gets recorded!

Please, follow instructions as shown on this page, and make sure you select either WASAPI or “Stereo Mix”, “Wave Out”, “Sum”, “What U Hear”, “Loopback”, depending on availability as an “Input Device”.

Note that the drop-down from which you can choose the “Input Device” in Audacity has a “microphone” icon to the left of it. This should not make you assume that all recording inputs must be made from the laptop “microphone”. In your case, you need to choose either WASAPI or “Stereo Mix”, “Wave Out”, “Sum”, “What U Hear”, “Loopback” from that drop-down.


Hi Robert,

Thanks very much for your suggestions. Only the leftmost ‘dropdown’ in my Audacity screen offers me the WASAPI option, so I chose it there. When I did that it caused the other dropdowns to default to Speakers (Conexant High Definition SmartAudio 221) Using PortAudio V19-devel, Speakers (Conexant High Definition SmartAudio 221) (loopback), and 2 (Stereo) Input, so I can see the ‘loopback’ you indicated.

Incidentally, my laptop is 3-4 years old, with Vista Home edition and I believe my system supports only 16-bit. Does that seem right to you? Still, I think I should be able to make a half-decent recording. I’m not looking for something that’s studio-quality. By the way, should I make some changes to the ‘Preferences’, e.g., the Quality option, where I specify Sample Rate, Sample Format, and so on? What about other options in Preferences?

I will wait for your (or someone else’s) feedback / suggestions.

Thanks to all.


Have a look at this page from the Audacity manual.


Here’s an update on what I have done so far:

(1) I followed-thru on the suggestion in the last reply and my settings match those indicated in the Manual for ‘Quality Preferences’.

(2) I think my Toolbars are OK (but I can’t guarantee it).

(3) I updated my sound card drivers (I followed the Audacity suggestion, i.e., I let Windows look for and then update the appropriate drivers). I then re-booted my system.

I am still a bit confused, however. When I check the Devices I find that it shows I have a Conexant High Definition SmartAudio 221 and an NVIDIA High Definition Audio. Are both of these devices sound cards? Which one should take over when I try to record streaming audio? Should I disable one of them?

At the moment my attempt to record results in a staccato (or machine-gun like sound) from the instant I start the playback, so I immediately stop it.

Any advice on fixing / improving my problem is very welcome. Thanks to all !!!


Hi Folks!

I think I have resolved my problem. Apparently I had Software Playthrough enabled (checked) and it needed to be disabled. When I did that and tried recording, the result was fairly decent — and really that’s all I am looking for. The sound is pretty much as good as what I hear when the playback occurs, so I am very satisfied.

Thanks to all who have assisted and offered suggestions and ideas !!!


Congratulations and thanks for letting us know.