Recognising a USB Port


I have recently damaged the USB Port, which I use when recording on my laptop using a Blue Yeti mic, and the USB Port is no longer usable for anything (everything worked very well until then) I have tried each of the other two USB ports on the laptop, but neither helps.

One of them seems to recognise the mic (As the mic’s ‘mute’ button lights up), but still won’t let me record. The other does nothing at all. I have tried changing the ‘Audio Device’ 'Recording Device and ‘Sample Rate’, and have updated the Drivers on my laptop.

Can anyone tell me how I can get the laptop (HP Pavillion g6, operating Windows 10) to let me use one of the undamaged USB Ports to record in Audacity with the Blue Yeti Mic?



Have you tried something else (maybe a thumb drive) on the “good” USB ports?

The USB ports are usually not entirely independent and they all may be bad if you shorted one out, or something like that. :frowning:

Have you tried another USB cable?

Have you tried the Yeti on a different computer?

First establish how many independent USB controllers you have. Right click the windows logo ( start button) select run and type in
Click on the arrow against USB Serial Bus Controllers. See if your USB microphone is listed either in this list or under sound video and game controllers. If you find the device right click and look at its properties to see if it says working normally. Right click the device and select uninstall device. Now reboot the computer and, provided the device is recognised, this will force windows to reinstall the drivers.
For further troubleshooting right click the speaker icon in the taskbar and select sounds. See if the microphone is present under the recording devices tab.