Recoding from cassette tape

The recording is being done at twice the speed, how can this be stopped and corrected? However, if you listen to the tape played via the computer (line in and headphone out) it is playing at normal speed.

I suspect that you have changed the sample rate of the track. Doing this will change the playback speed.
You can set the required recording sample rate by either setting the default rate in Audacity Preferences (Edit Menu > Preferences > Quality tab), or by selecting the required project rate from the box in the lower left corner of the main Audacity window.