Re: record only 5 seconds / graba 5 segundos[SOLUCIONADO]

Hi, I´ve been using Audacity in Windows XP, but now I have a new computer with Windows 7. I´ve download the last Audacity version and now, each time I try to record, as the bar moves, each 5 seconds (aprox.) the sound is erased. The bar continues recording and again, each 5 second is erased. If I stop it, no sound has been recorded at all. It works as a demo version. Is it possible?
In the other hand, when importing sounds directly, I can not see the sound waves, but diagonal lines erasing the sound. It still sound properly, butI have no options to make any change or even see nothing.
I hope you can read and understand my translation.

Hola. He cambiado de ordenador y antes usaba Audacity en XP sin ningún problema, pero ahora he descargado el Audacity 2.0 en Windows 7 y sí que los tengo. Aparentemente funciona, pero tal y como va desplazándose el cursor al grabar, cada 5 segundos se borra lo anterior. O sea que no me sirve para nada.
También me pasa que si importo un archivo de sonido en bruto no aparecen las ondas de sonido sino un rayado en diagonal que no me permite hacer nada con ello, sólo escucharlo sin más.
(Da la impresión que sea una versión Demo. ¿Será eso o me falta algo por configurar?)

Is the picture of the waveform being erased, or is the sound itself being silenced so that when you go to playback the sound, nothing is heard?
If it is the sound being erased, make sure your hard drive has enough free space on it to record.
Perhaps it would be helpful if you could post a screenshot:

That sounds like the “On-Demand loading” working (correctly):

Check in “Edit > Preferences > Directories” and ensure that “Play and/or record using RAM” is not selected (not enabled).

Thanks. I’ll try to send a screen shot. I confirm the wave is erased and nothing remains longer than five seconds. It can not be a problem about hard disk capacity because it is a new computer with no high performance programs inside nor documents, it is nearly empty except the McCafee anti-virus.
Thanks also for the second answer, I’ll try to be more patient next time.

Open the “Directories” Preferences again. What does it say for “Location” of “Temporary files directory”?

Opposite the box that shows the location, try pressing “Choose…” select a different directory, click OK and OK, then restart Audacity.


Thanks Gale Andrews and Steve for your solutions, but the problem still remains. It is surely a little detail, but I can not find it. I´m trying to send a couple of screen shots…

…but I´m afraid I´ve failed again. Maybe it´s not a good idea doing it by Facebook.
I keep looking for the answer to this mistery. If I find the solution (probably the most stupid one), I´ll let you know for your cooperation.
Thanks anyway.

You can attach an image by using “Upload attachment” underneath the message “Preview” and “Submit” buttons.

From your description, and assuming you have not yet saved an Audacity project, Audacity cannot write to the Audacity temporary folder when it tries to write the waveform every 6 seconds. That is why I asked exactly where the Audacity temporary directory was.

Please click Help > Show Log…, then Log > Save… and attach the log file.


Thanks Gale. I have news about all this. I´ve tried to uninstall Audacity and Downloaded again. Nothing had change. But then, I´ve tried to open a WAV file. Then I saw all diagonals but the sound was correct. These diagonals remains apparently forever. BUT THEN I´ve saved this WAV file as an Audacity one and then surprise surprise! As soon as I´ve opened again as an Audacity file, the wave sound is there! And it sounds good. EVEN BETTER, if I record anything now, there´s no problem at all, but I´m still inside the file I´ve loaded. So I can record here and “save as…” without any problem. But if I close the program and re-open it, I have the same problem: can´t record anything. It is a little bit strange, isn´t it?
In the other hand, I could attach the “Log” information (full of errors), but it is in Spanish. Even more, I don´t know if it should be attached as “Quote” or “Code” or “List” or “List=” or “[*]”. I´m sorry about that. By now, I can use the “manual procedure” I told you.
If, according to this new information, you can suggest any other thing to me, I´ll keep an eye on the forum. You are really helping me a lot. Thank you.

Nothing would change. You currently have to exit Audacity and reset the audacity.cfg file using these instructions in order to reset Audacity settings.

The diagonal hatching from On-Demand Loading should not stay forever. This and the fact that you can only record to the folder you saved the project to still indicate that Audacity is not writing correctly to the temporary folder noted in “Directories” Preferences.

Quit and restart Audacity then record for a few minutes. If the waveform still disappears every six seconds, click Help > Show Log…, then in the log, click Log > Save… to save a .txt file. Then use “Upload attachment” (underneath where you write replies) to attach the log.txt file.

Also please attach the “audacity.cfg” file from C:UsersAppDataRoamingAudacity . If you cannot see that “Audacity” folder, follow these instructions to show hidden files and folders.

If you want a quick attempt at a solution, before you attach the log and audacity.cfg, press CTRL + P on the keyboard to open Preferences, choose the “Directories” Preferences (twelve items down on the left - it is called “Carpetas” in Spanish) then use the button to select the same directory you saved the project to. Click OK then Audacity will create an “audacity_temp” directory in that folder to use as its temporary directory. Now restart Audacity and see if you can record.


OK, let´s try again. In this message, you should receive the log.txt and the audacity.cfg files.
While sending this message, I´ll try your second solution, but I think I did it already and it wasn´t worked.
audacity.txt (4.6 KB)
log.txt (62.9 KB)

Gale, it seems that works!! I´ve resetted the audacity_temp file (I think I did it before, anyway) and it works. I cannot understand why audacity didn´t like the previous ubication. It doesn´t matter. This time I´ve gone directly to the “Escritorio” (I think the word in English is “topdesk”, the first screen you see when opening the computer, where normally you get access to all the icons to select the program you need and so on). So now I can see the file audacity.temp each time I open the computer so I suppose I´ll move it again to a better place (knowing that I can returned again to the “topdesk” if it fails again).
Thank you very much for your help and lessons.

I am glad you can record again without saving a project.

Your temporary folder location was set to C:Program Files (x86)Audacity 1.1audacity_temp but Audacity could not write there. This may be because you were not logged in as an administrator which is usually required to modify Program Files folders.

The default location for the temp folder for you would be C:UsersPaqueroAppDataLocalTempaudacity_temp. You can write to your “Users” folder without administrator permissions.

If you want, you can exit Audacity, then paste the attached audacity.cfg file into C:UsersPaqueroAppDataRoamingAudacity (the folder you found audacity.cfg in before). Say yes to overwrite the file. This .cfg keeps all your settings but sets your temp folder to the Audacity default location in your “Users” directory (as above), so you don’t have to look at the temp folder on your Desktop.

audacity.cfg_fjmiron.txt (4.6 KB)

This happened to me as well, I looked at the temp folder location and I did not have permissions to write to it. I moved the temp directory to a location I can use. very annoying I did not get a warning at all!

You should always be able to write to your own Users folder in which Audacity places the temporary folder by default.

Help > Show Log… in Audacity would show errors but unfortunately it isn’t possible at the moment to make an error message from the logged errors.