Re-downloaded audacity and now it records differently

Before I did system restore, I was able to start a click track, record something while hearing the click track, and then I was able to remove the click track and all that was left was what I had recorded. Now it records both the input and the click track. How do I get it to revert to how it was before?

You’ve probably set Audacity to record from “Stereo Mix”. Check the recording input settings in the Device Toolbar and ensure that it is set to record from the actual device that you want to record from, not from Stereo Mix.

I tried that and it didn’t work. I think what I meant to say was that back then, when I wanted to record a separate part that laid over the first thing I recorded, they would be treated independently. It’s like if I tried recording a bunch of chords in part A, Part A would be picked up while I’m recording Part B over it. They used tor record independently of each other.

You’ll need to say more about what device you are recording with and how it is connected to the computer.

Wear headphones, if you aren’t already.

Don’t record from the built-in mic.

If you are using a mixer, connect “CD/Tape out”, “Main output” or the “Alt 3/4” output from the mixer to your computer (not the control room output).