Raw data import - wav file > 4 Go

Hello.

I have recorded a 4-h .wav file with DVBViewer. The recording parameters had been mistakenly set to 32 bits float instead of 16 bits. I obtained a 5.4-Go .wav file that I cannot open completely to have it edited (all audio editors, Audacity included, open only 53 minutes over the four hours).

I tried to import the file as raw data in Audacity 2.3.3, trying different combinations of options. Nothing worked: in all cases I obtained a saturated waveform. What can I do in order to open and edit this file? (Please note that I have not installed the FFmpeg Import/Export Library yet, thinking it useless.) The audio file is fine (DVBViewer can play it completely.) Thank you for your help. Regards.

What does that mean? Do you mean “a 4 hour duration .wav file”?


What does that mean?


What does this website say about the format of the files? MediaInfoOnline - MediaInfo in your browser


Note that the maximum size for a normal WAV file is 4 GB WAV - Wikipedia

Probably, everything is fine except the file size field in the file header which is limited to 32-bits (4GB). If it “rolls over” you loose the most significant bit(s) and the playing time gets all fouled-up.

Raw import should work if you get the parameters right. Try an offset of 44. (A standard WAV header is 44 bytes and the audio data should start at byte 44.) Or if you still get “scrambled data” try offsets of 0, 1, 2, or 3.. With 32-bit audio there are 4 bytes per sample, so one of those values should get the bytes re-assembled correctly. If the left & right channels are reversed, add 4 to the offset (if you care about that).

With a small offset (less than 44 bytes) you’ll get a little glitch at the beginning where the header is converted to audio. You can trim that out once the file is open in Audacity.

(Please note that I have not installed the FFmpeg Import/Export Library yet, thinking it useless.)

Right. If the audio is uncompressed FFmpeg won’t help.

The recording parameters had been mistakenly set to 32 bits float instead of 16 bits.

It’s normal for Audacity to “record” and work-internally at 32-bit floating-point. There are advantages to doing DSP (digital signal processing) in floating point. When you export, you can export in the format of your choice. (You are actually recording/capturing at the bit-depth of your soundcard or interface and Audacity is making the conversion.)

Thank you for replying.

I have tried with 32 kbits float, big-endian, and offsets of 2n+1, 2n+2, 2n+3, 2n+5 until 53. For all offsets but 2n+1, I obtained a completely saturated wave fonction (attached document, top). For offsets of 2n+1 (1, 5, 9, etc.), I obtained a very tight dark-blue waveform between 0.5 and -0.5, but a light-blue waveform that resembles something usual (attached document, bottom). Nevertheless, this is no usable signal.

Any idea?

Thanks.
Waveforms 01.pdf (577 KB)

What does this website say about the format of the files? MediaInfoOnline - MediaInfo in your browser

Hello.

MediaInfo says:
Wave: 5.15 Gio, 3 h 59 min
3072 kbit/s, 48.0 kHz, 32 bits, 2 channels, PCM (IEEE) float.
Constant bit rate

Thanks for your help.

Please post the full information - just copy and pasted from the web page. For example:

General
Complete name                            : myfiles.wav
Format                                   : Wave
File size                                : 53.0 MiB
Duration                                 : 5 min 15 s
Overall bit rate mode                    : Constant
Overall bit rate                         : 1 411 kb/s

Audio
Format                                   : PCM
Format settings                          : Little / Signed
Codec ID                                 : 1
Duration                                 : 5 min 15 s
Bit rate mode                            : Constant
Bit rate                                 : 1 411.2 kb/s
Channel(s)                               : 2 channels
Sampling rate                            : 44.1 kHz
Bit depth                                : 16 bits
Stream size                              : 53.0 MiB (100%)