Raspberry Pi 3 b+ USB multitrack recording stutter

Hi!

Today I tried doing some multitrack recording with a Raspberry pi 3 b+ and a 16ch interface connected via USB. Audacity is running on the latest x64 version of raspbian and installed via sudo apt-get install audacity.

All 16 channels are recorded at 48khz 32bit, which is the format the usb interface is using, but no matter if i record one or 16 channels the audio is stuttery, like if it was an analog recording filled with dust and pops in the audio. I have also tried 24bit at 48khz but it still persists.

I am using an external HDD connected to USB 2.0 and load there the cache files of audacity.

Any ideas on what is causing this problem? I tried the same scenario on windows and no problem. I also tried arecord and it did a bit better than audacity.

My guess: Insufficient processing power of the hardware to handle 16 channels of 32-bit data at 48000 Hz.

Things to try:

  • Try dropping the sample rate to 44100
  • Try using Audacity 2.x (The final version of the 2.x series was 2.4.2)

Okay. Dropping the rate didnt do anything.

I can’t really find verison 2.4.2, do you know how I can Install it?

Old versions of Audacity are available from Old Audacity versions download

Thanks. For version 2.4.2 I can only see source code for Linux. Does that mean if I want version 2.4.2 I’ll have to build it myself?

16 tracks can be a challenge for a regular computer!

One POTENTIAL advantage of the Raspberry Pi is that there is probably less junk running in the background but the operating system is ALWAYS multitasking and interrupting no matter what.

For Windows, there is a free online book called Glitch Free about optimizing for audio. But since Audacity doesn’t support ASIO (unless you compile it yourself) multitrack recording can be difficult or impossible with Audacity on Windows.

REALISTICALLY, if you are recording & mixing 16 tracks you should consider using a Computer and a DAW application.

Yeah the pi is great for having it in backstage and not worry about it. No as a regular laptop would be.

So, I shouldn’t have ANY hope on this?

“Binary” (ready to run) releases of Audacity for Linux are quite a new thing. Prior to Audacity 3.0.3 there were no AppImage releases from the Audacity team.

Two options for running Audacity 2.4.2:

  1. Build from source (instructions are included in the source code)
  2. Use a slightly older version of Linux (Anything based on Debian Bullseye is likely to have Audacity 2.4.2).

The second option is easiest.