Random loss of sound - Audacity 2.3.0

Audacity 2.3.0, Windows 10, version 1809

Hi, I experience a Random loss of sound problem which has been described for an older version here https://forum.audacityteam.org/t/random-loss-of-sound/1772/1 - without a satisfying answer (see the last post to the thread).

The loss appears for a couple of seconds without an apparent reason - I have multi-(50)-track project and on two places of the project there is a sudden silence even-though the tracks are apparently there. If I copy a track from the “silent place” to a new project it plays with no problem. That means that the problem is not in the track but somehow in the combination of tracks or something like that. Could somebody please help me on this?

When you press “Play”, is there a noticeable pause before playback starts?

I would not say so - maybe a 0,25 s (estimation)

I’m wondering if your system is getting close to the maximum number of tracks that it can handle. One way to test is to see if we can make the problem worse. Add a few new audio tracks, and generate some silence into them. Does that make the problem noticeably worse?

I added new tracks (more than ten), generated silence, then generated noise.
No change, still the same place stays silent (or two places of the song close to each other - in one specific section - mid-track - that is, no whole section disappears). So the problem does not seem to be the number of tracks.

Some additional info

  • I originally made this track in older version couple of years ago (I only wanted to revise it, rename and organize tracks and make minor changes)
  • The part where the sound disappears, is where tracks play that I applied some effects to (wah, G-verb, reverse). I applied them before, in the older version, a couple of years ago

Thanks for checking. That would appear to rule out that possibility, so we move on…

If you solo a track that has a silent bit of waveform, does it play correctly or does it still have the problem?

All the tracks that play during the moment of sound loss (cca 8 out of 50) become silent (i. e. whole project) - it is not the matter of one track. But if I solo any of those tracks, it plays without a problem (without a loss of sound).
Interesting fact is that I noticed is that the sound loss beginning is tied with the beginning of one of the tracks. (That tracks plays normally as well when soloed)

I suspect that what you may have is “phase cancellation”. If you’re unsure what that means, please ask and I’ll illustrate the issue.

I haven’t heard about it before, is there a way I could solve it without changing a track?
Interesting is that in the older version the track was the same and I did not have this problem.

Phase Cancellation:

Try this as an experiment:

  1. Launch Audacity
  2. Generate a tone (Generate menu)
  3. Play - check that you can hear the “beeep”
  4. Select All (Ctrl + A)
  5. Amplify the track to about -10 dB (minus 10) so that it is not too loud (Effect menu > Amplify)
  6. Duplicate the track (Ctrl + D)
  7. Select the second track by double clicking on the waveform
  8. Effect menu > Invert
  9. Play - note that there is silence
  10. Use the “solo” / “mute” buttons to listen to one track at a time, note that both will play individually, but when played together there is silence.
  11. Zoom in very close on the waveform (https://manual.audacityteam.org/man/zooming.html), and you will see that where track 1 goes positive, track 2 goes negative, and vice versa. The second track is an inverted copy of the first, and when they are played together they exactly cancel each other out.

That is “Phase Cancellation”, (the example should look like the image below).

Now that you know what phase cancellation is, check your project carefully to see if you have duplicate, inverted tracks.


I tried the experiment you recommended:

When I played the tracks I generated (one of which was inverted) I still heard the beep, although, strange enough, there was a short fade-in in the beginning. Nonetheless, I concentrated on my tracks for I knew there was some inverting and some effects that could cause phase cancellation and I eventually managed to resolve the problem - remove the silence.

The problem as it turned out was not the phase cancellation. I can’t explain in technical terms but I will try for it seems to be kind of bug:
There were two silence passages in the project and two tracks which, when muted, caused the project to play without silencing (each track for one silence passage).

One of the tracks was silenced to zero by envelope. Still caused problems when not muted. I tried to silence it by function “silence audio selection”. Still caused problem. So I removed the envelope (which was now, after silencing selection, unnecessary) and the problem was gone. So I concetrated on the envelope on the second track as well. What both tracks had in common was something like “one almost unnecessary envelope point” - that white dot for editting envelopes, that was muting the track to zero to make fade-in from zero. I removed that point (substituted it by fade-in effect) and the second silence passage was gone.

I do not see much logic behind it. I did not face the problem in the older version.

Still, thanks for your patience and guiding me to find the solution.

Best regards.


I don’t understand what the problem was, but I’m glad to hear that it is now solved.