Random blanks during recording

Windows 11, A 3.1.3 (but also 2.1.3 Portable Version)

Dear all,

I’ve been a basic user of A for years. Out of nowhere, when I record myself I get these “blanks” - it keeps recording but with a flat line, there is no noise in the background or anything. When you play it back, you can hear these mini cuts… but my own voice sometimes disappears.

I have never fiddled with A preferences or anything so no idea what is going on… but it is not use at the moment!

Any help?


How long have you been using Windows 11?

What’s the microphone and how is it connected?

when I record myself

Your voice, right? You’re not playing a saxophone or anything?

Are you working from home? Do you “Zoom” into the office or Skype into meetings?

Do you share games and commentary on the internet?

How does your internet connect?


Thank you very much for your reply!! To answer your questions:

How long have you been using Windows 11? - I updated from W10 to 11 in January

What’s the microphone and how is it connected? - Mic Integrated (Laptop), Realtek Audio, Driver Updated and Troubleshooting shows nothing wrong

when I record myself. Your voice, right? You’re not playing a saxophone or anything? - That’s right. Sometimes it starts off allright but the problem starts a few seconds later

Are you working from home? Do you “Zoom” into the office or Skype into meetings? - Once I day using Google Meet
Do you share games and commentary on the internet? - No
How does your internet connect? - Wifi

Random blanks during recording

That’s pretty unusual. If the data stream fails, Audacity will just stop dead and wait for it to resume—you don’t get silent stretches. If the microphone system fails, Audacity will go looking for a working microphone, but then doesn’t come back by itself.

If the microphone passes general health tests, then there’s something between the microphone and Audacity.

Try an experiment. Shut down the WiFi. Clean Shutdown the machine. Shift+Shutdown > OK > Wait > Start. Do Not let anything else start. Run Audacity and make a recording. Still do it? I know the goal is a clean recording, but it’s important to note if you do something and the problem gets worse.

I’m assuming you’re recording on the machine’s internal drives. Audacity doesnt get along well with External, Network, or Cloud drives.


There is a more evil version of this. Note if something complains bitterly when you shut down the WiFi. You’re not the only user on your machine.

Twilight Zone moment.


Sorry for the late reply and thank you very much for your help!

I tried everything you suggested to no avail; mic health tests were ok, BUT: I tried recording a video with the Windows’ app and I got the same problem. It’s not exactly 100% blanks that I get, but rather a 98% silence at random points…

So it’s not audacity after all, but I have to admit I haven’t got a clue how to solve this…

How long are each of the blank spaces? Several seconds? A small fraction of a second?
How frequently do they occur? Every few seconds? Every few minutes?

At completely irregular intervals… it is very strange, I’m considering reinstalling Windows because I’m out of ideas…

This can get complicated and I don’t have the “answer”… :frowning:

Ther is a FREE online book about optimizing your computer for audio called [u]Glitch Free[/u]


[u]Dropouts[/u] are normally related to multitasking and your operating system is ALWAYS multitasking, even when you’re running only one application.

The audio data comes into a buffer at a smooth-constant rate. A buffer is like a storage tank or a long pipe. When the operating system gets-around to it, the buffer is read in a quick burst and the data is written to the hard drive. If some application, process, or driver “hogs” the system for a few-milliseconds too long, you get buffer overflow and a dropout or glitch.

A bigger buffer sometimes helps. (Or sometimes a smaller buffer helps, but I don’t know why.) You can change the buffer size/latency* under Preferences → Devices. (I sort-of suspect there’s another “hidden” buffer somewhere but that’s just a "feeling’.)

A faster processor also usually helps because it can finish-up the background tasks quicker. ANY modern computer is fast-enough and powerful-enough for “simple stereo recording” but the gotcha’ is all the stuff Windows (and applications) is doing in the background. Note that whatever is hogging the system doesn’t have to be hogging lots of total CPU cycles… It just has to hold-onto the system for a few milliseconds too long…

Usually these dropouts are short-duration and in your case something else may be happening to interrupt Audacity…

There is also a playback/monitoring buffer that works in the opposite way. It’s filled in a quick-burst and data flows-out at a smooth-constant rate. Here the danger is buffer underflow (where the buffer “runs dry”.)


  • A buffer introduces a delay (latency). This can be a problem if you are trying to “perform” while monitoring yourself on headphones with a delay. Otherwise there is no issue with a big buffer and long latency.

Thank you very much for your educating reply - I’ve being fiddling with it to no avail for too long, so I’ve given up and will format and reinstall ev from scratch this summer. I know it can’t be the laptop, I bought it a year ago and it-s a beast capable of playing the latest games at full specs… so for the life of me I can-t figure out why it won-t record a simple 5 min audio properly…

I’ll report back if I solve the problem!

Did you find the solution to the problem?
I have the exact same problem!
I’ve probably tried everything to solve this, but to no avail…
At this point I’m just staring at the screen helplessly.

I would greatly appreciate a response on the topic.

There’s some possible solutions here: https://manual.audacityteam.org/man/faq_recording_troubleshooting.html#skips

Thank you for your reply

I unfortunately tried every single one already…
The day before the dropouts started showing up in the recording I was fiddling with the drivers because I lost the realtek menager.
I got it back, and then noticed the dropouts. My system is really good and never had trouble with something like this for 2 years now.
I’m thinking of reinstalling the sound drivers and the system, because I’m out of ideas.

Ok after reinstalling the drivers from the official motherboard disk the dropout problem seems to be gone…
Though I can not say for certain since it is completely random.
I also installed from the disk an intel tool that is supposed to make SATA drive communication better or something, idk really if that solved it or the audio drivers, but it works now!
I am so relieved.

The bottom line of that FAQ links to this page: Missing features - Audacity Support where you will see that there’s a section about drivers.

Ok UPDATE on the topic.
I have finally for certain eliminated the issue.
The problem was with the drivers.
I fixed it by going on the website of the manufacturer of my motherboard, which in my case was Gigabyte.
Then I proceeded to download every sound driver there was and I just had to figure out which one worked for me.
The one from 2018 worked, and fixed all the issues!
Probably because my motherboard is a little old…

So the problem is finally, SOLVED.