Random Audio Appears When Exporting

Audacity (for example 2.0.0)
OS X 10.6.8

When I export audio which I have recorded into audacity, it inserts a random short clip of audio when I export, usually at the start of the audio recording. As I am exporting dance tracks, it can sometimes insert an extra beat at the start of the track where there should be silence, or another part of the track.

It only inserts a very short piece of audio but it can be extremely annoying as I do not know how to stop this. The audio that I am recording into audacity is vinyl which has been routed through into my Audio Kontrol 1 interface. When I listen to the audio in audacity, it appears fine. When I listen to the exported .wav, there always appears to be a random piece of audio inserted at the start of the track which comes from nowhere.

How can I stop this?


You can tell by all the elves racing to your rescue that this one isn’t easy. You appear to be doing everything perfectly correct, but it doesn’t work. I need to go back and read that again.

Do the WAV files play correctly anywhere else? Do they play on you mom’s computer? Your sister in Schenectady?

Are they still broken if you pull them back into Audacity and play them? Like export, watch it break, restart Audacity and open it.

Can you post a sample of WAV that has the damage at the top?



It’s a little fuzzy: Your exported WAV actually has an extra musical drum beat in the song, or it’s just slightly longer than you thought it was going to be? You said extra beat where there should be silence. Actual silence as in a data track with nothing in it, or you just left a blank hole expecting there to be silence when you exported?
Audacity will ignore “holes” in the show. If you need silence to make the rhythms work out, you need to generate it or copy and paste from somewhere else in the show.


I am only exporting a recorded vinyl. So there is silence before the song actually starts as the vinyl rotates round.

So in audacity you can see the silence but once I have exported the track, sometimes there is random sounds added to where there should be silence at the start of the record. It appears that if I play a short bit of the track before exporting, audacity then imports part of the audio from the last location of the player head to the start of the track.

You do only have one Audacity track open when you export, I take it? Nothing underneath the track you recorded?

Is it possible to save an Audacity Project (File > Save Project) that reliably does this when you export? Preferably it should just be a three minute song. Zip the .aup file and _data folder, post it to one of these sites

https://castle.so/ (maximum 256 MB)

then give us the web address to download it.


This does not happen with every track on every export and the results are not always the same. With the .aus that I uploaded, when I export this track, it had decided to add a tiny synth sound before the first beat kicks in. This should NOT be there and I don’t know why it has added it. You can hear this with the .mp3 that I have included with the uploaded .zip.

Is this a setting within Audacity that I should change?

The small synth sound doesn’t sound life threatening but sometimes it can add a kick drum and confuse me when I’m DJing and cueing up the track.


Thanks for the project and MP3. The project has audio behind zero that is being exported (see the ← arrows to left of the waveform). You can switch to Time Shift Tool (F5) to drag the audio rightwards and hear what is behind zero.

If you are using Export Multiple, this exports audio behind zero.


I was using the single export. This appears to have fixed it for now. I will make another post if this happens when I record a new vinyl in the near future!