Quick help with some audacity delay (Not the effect)

Hello everyone I am new to this forum.

So I am using Audacity to record my instruments (Guitars Keyboard) and make tracks to make acoustic songs without vocals.

Let me tell you a little about my setup here.
From my guitar the signal goes straight into my guitar amp. It goes out of the amp via the headphone jack which then goes directly into the line in of my computer, and finally out through my headphones. whenever I play my guitar NOT recording with audacity there is no time difference from when I strum my guitar to when I hear it in the headphones. But when I press the record button there is about a quarter second delay from when I strum the guitar to when It shows up on audacity and thus, to my headphones.

I don’t understand why the delay is there when I record but not when I play when its not recording.

Any tips or solutions would be greatly appreciated.

If it helps I am running audacity on windows vista.

When you’re just sitting there with no Audacity, your machine is set to turn your input straight around to the output with little or no processing. When Audacity gets in the act, Audacity is doing the management which means now the sound is one computer late. This is happening in Audacity Preferences > Devices and Recording. Try turning off Playthrough and Overdubbing and then go into Windows Control Panels and select Input for Playback.

The problem with that is when you start overdubbing or multi-track with your music. You have to listen to your own voice or guitar versus an existing track in real time. If you never want to do that, then there’s no problem.


What exactly do you mean set the input for Playback?

Look in the Transport menu and ensure that “Software Playthrough” is off (not selected).

Still doesnt work.

But since I clearly can’t get the timing right on any tracks. I have to use the time shirt tool to line up both tracks so they are in sync.

However when I do that the time shift tool just moves both track simultaneously rather than moving one.

How do I isolate the two separate recordings and then put them back in time?

And your headphones are plugged into what?

Don’t have both tracks selected.
(Click on a track with the normal selection tool before switching to the Time Shift tool)

Have you set up the Latency Correction properly?

A word.

Computers have two different delays, Recording Latency and Machine Latency. A Recording Latency error means you can sing in perfect time to an existing or beat track and the combined result plays off time, sometimes significantly. Audacity has the ability to remove that one in Preferences > Recording > Latency. The software plays the beat track to you at an odd time, so the new round trip comes out in perfect rhythm on the timeline. Piece of cake.

Machine Latency gives you your own live voice back to you late. Always late, and you can’t change it. The only way around that is not hear your own voice in the mix or extraordinary software management or money-based hardware. That’s the hard one. The cheap way out is not listen to yourself during the recording, or sing into your cupped hand to form a tunnel to your ear.