Putting slight delay on recording?

Whenever I record, my microphone keeps picking up the sound of me pressing the keyboard. Is there any way to add a slight delay to the start of recording, to avoid this? Really annoying to have to go and snip that sound from the beginning, every single time I record anything.

No there isn’t.

Press the button more gently?

Are you recording from a microphone plugged into the computer’s sound card? If so, make sure in your sound card’s control panel that “tie up same type of input jack” is not selected. If deselected, this might stop external mic recordings also picking up what the internal mic hears.

If necessary, once the external and internal mic are separated into different devices, you can disable the internal mic in Windows Sound.


I am. I’m pressing Shift-R to append record; doesn’t exactly require much pressure.

The keyboard and microphone are on the same desk; that also might be the cause.

I’m recording using an external USB mic. My computer doesn’t have any other microphones.