Punch and Roll doesn't work on RPi 4

OS: Ubuntu Server 19.10.1 w/ LXDE on Raspberry Pi 4B 4GB
Audacity: 2.3.2; installed from distro using apt

When I press shift-D the audio after the cursor is deleted but preroll playback never happens, nor does the continued recording MOST OF THE TIME. On rare occasions it works flawlessly.

I can’t seem to find any patterns in why it does or does not work. I tried repeatedly pressing shift-D then ctrl-Z and it worked on the 12th and 43rd attempts, but none of the others.

Does appending a recording with the “R” key work reliably?

Yes, both R and shift-R work.

Does it make any difference if you change the “Punch and Roll” shortcut to something else? (see here for changing shortcuts: https://manual.audacityteam.org/man/keyboard_preferences.html)

Changing the hotkey to M produced the same inconsistent results. I also tried using the menu option to no avail.

As this is the only report that we’ve had of this problem, my guess is that it’s specific to the very low spec hardware. I shall report the issue to the developers to see if they have any ideas. I’ll post back if I get any information or suggestions.

Is there a way to get the Audacity 2.3.3 ARM build pushed to the Ubuntu Eoan/Focal package repo? Currently it’s at 2.3.2, which is where I’m having this problem. I wonder if a different version might solve the issue.

The Audacity developers do not build packages for Linux distributions. That’s done by the “package maintainers” of that distribution.
In the case of Ubuntu, the Audacity package maintainer is “Ubuntu MOTU Developers”.

I’ve found the cause of the issue. Selecting the audio input device directly in Audacity was somehow causing the problem. I was able to replicate both the bug and the fix on an X86-64 install of audacity 2.3.2 on Lubuntu 19.10. Whether that is a quirk of my particular mic (AT2020USB) or a bug in Audacity is unknown to me.

The “fix”, as it were, was to unplug my USB microphone and then start Audacity. This resets Audacity’s input device to “default”. Punch-and-Roll Record then works flawlessly.