Punch and roll clip boundaries not always appearing

Operating system: 11.5.2 Big Sur
Audacity version: 3.1.3

I record audiobooks in Audacity. It’s been going well for ages.

Lately, about 1 in 3 times I punch in, the clip boundary doesn’t appear so I have no marker of when I began that take. This is hugely frustrating as I jump to every clip boundary to clean up unusual gaps, double breaths, etc because I never start speaking at the exact second I intend to.

If relevant, my pre-roll setting is 3 seconds, my crossfade 10 ms.

Grateful for any help!

FWIW, I did some testing on this. The behavior is odd–on the offending occurrences, the clip boundary is created at the punch-in point when the Punch and Roll Record key (Shift-D) is pressed. But, when the record head moves past the punch-in point, the clip boundary is removed and recording continues, extending the existing clip. As OP noted, this only happens sometimes, and I haven’t been able to narrow the specific conditions to replicate the problem.

I cannot reproduce this on W10 with 3.1.3


Nor can I reproduce this with 3.1.3 on my Macbook Pro with macOS 12.2.1 Monterey,


Thanks for replying. I’m relieved I’m not the only one.

Should I revert to a previous Audacity I wonder?

I wouldn’t recommend any earlier version of Audacity 3.x due to bugs (many of which are fixed in 3.1.3).

If you really want to go back to an older version, Audacity 2.4.2 was the culmination of the 2.x series and is generally stable and reliable. However, note that it uses the old “AUP file + _data folder” format for projects rather than the new single “AUP3” file format.

I’d call this a worse bug to be honest. It causes me so much extra work :frowning: I’m about 1 hour of stress away from abandoning Audacity which I’ve used for years, this is such an important function to me and I use it constantly.

Audacity 2.4.2 has Punch and Roll.

I can reproduce this behaviour on 2.4.2 (my pre-roll is 5 secs). It seems to occur around 25% of the time, with no obvious behavioural cause.

However, it is instantly noticeable when the glitch happens. A thick grey boundary is created immediately when all’s working well, so if the editing cursor remains thin during the pre-roll, I know what’s coming and can just pause (space bar) and shift+d to retry, with minimal disruption to workflow. Curiously, it always works properly if I pause and retry before the playhead passes the punch-in point.

Not sure if the glitch is as immediately noticeable on 3.1.3 with the new clip architecture. How does the boundary present during pre-roll when working correctly? Can you tell immediately if the glitch has occurred even before reaching the punch-in point? If so, the above might help you avoid later hassle.

Possible workaround if you continue despite the lack of a boundary: the playback start position cursor and the editing cursor beneath it (thin vertical line) remain at the punch-in point unless you move it, so provided you haven’t moved it mid-take, you can quickly create the boundary yourself with cmd+i next time you pause recording.

Not sure if the same is true on 3.1.3, but anyway - worth experimenting before you roll back to 2.4.2, cos it seems the glitch isn’t 3.x.x-specific.

Unfortunately, Audacity 2.4.2 is an old version and no longer maintained. Any bugs in that version will not be fixed. The current version is Audacity 3.1.3.

Yes, I know that. Was just posting so that the OP will know not to expect a roll back to 2.4.2 to fix the issue.

Punch and Roll has been flagged for attention in Audacity 3.2.0 (alpha), so hopefully this might get fixed for the next release.

Here’s a screenshot:

As an update, since this issue continues to frustrate me every day, I’m now on Mac 11.6.5 Big Sur, and I decided to install Audacity 3.1.2 to test. When in pre roll, there is no visual change when the clip boundary fails, so I might have to revert back to 2.4.2 so I can see it failing.

Here’s a screenshot of my experiment: https://imgur.com/a/C49Y4lt Every second, I punched in, and all worked. I thought this was remarkable. I have a terrible error rate when narrating. Then I tried saying “this is a test” and punching in every 3 seconds. It failed 3 times in a row, then every other time (these are the lines I’ve drawn)

When the clip boundary doesn’t show up, obviously I know it’s failed, but by the time the pre-roll plays I am looking back at my script, mouthing along my previous line, and acting. Not staring at Audacity. My next flub could be 2 minutes later, so it’s not immediately apparent that the clip boundary has failed. Sometimes it seems as if I’ve made no mistakes in 5 mins and I have to go hunting for half-breaths and suspiciously large gaps, and adjust my pacing.

Could this be RAM related?

I know this is a stretch. I’m at a loss why Audacity started misbehaving these past few months when I had a trouble-free ride for so long.

Hmm, I’ve got nothing I’m afraid, except the aforementioned 2.4.2 workaround. And as you say, that only works if you’ve got eyes on Audacity - fine for me cos I have my script on the same screen and a leisurely pre-roll, but no good if you’re reading from paper/another device.

If a paper script, maybe a quick mark to note the punch-in points as you go, then tick them off when editing to ensure you pick up the missing boundaries. Might result in a net gain, faff-wise.

Same here, glad I’ve installed the new audacity on my laptop first. Seems I have to keep using my old version.

For audiobook narrators seeing the boundaries is really a very useful thing!
And especially the new feature of lossless trimming at these punch in points would be such a big advantage, but right now is not applicable.

My big wishlist for audiobook narrators and similar:

  • Punch and roll creating a new clip
  • a cutting option that includes the lossless trimming advantage: Right now, when you cut something, you don’t see a boundary, the clip is merged, so you can’t restore it. If instead the clip were divided into two and the gap automatically closed (like a magnet), one could restore parts that were accidentally cut off. But this would include the wish for different behaviour on clip boundaries: e.g. magnetic to the previous one, or moving all clips after the one you are re-opening a little further to make space again etc.