Pulsing audio on playback via USB

(MacOS 10.14.6, Audacity 2.4.1) During playback when output is to USB the audio “pulses” at about 10 pulses per second.

Playback via Mac built-in (headphone) output works fine.

I use a MOTU M4 digital interface connected via USB.

All other apps work fine: Reaper, iTunes, YouTube, Zoom, etc. Only Audacity presents the problem. I have pored over all Audacity Preferences settings, System Preferences settings and settings in other apps to try to find the problem. Any help appreciated.

Have you tried resetting prefs? See:


Delete audacity.cfg in

~/Library/Application Support/audacity/

To access that folder, use the “go” menu and select “go to folder”. Paste the above path into the resulting dialog box.

By experimenting I found a solution. Under Preferences>Device>Buffer length I found that reducing the buffer length from 100 milliseconds to 60 milliseconds did the trick. I have no idea why this worked, but the problem seemed to be some sort of buffer fight. Thanks for your help.

THANK YOU for this. I was having the same problem. [Playback through USB interface (MOTU M2 in this case) suddenly was exhibiting rapid-fire stuttering/pulsating. Playback was fine using computer audio. Or if I exported track(s) to audio file, playback through USB interface worked fine in Quicktime or iTunes. Audacity/USB interface was the problem]. Could not figure out what was going on.

Setting the buffer to 60 (from default 100) did the trick. Thanks again.