Provisionally Solved v2 Linux unstable and many issues

Audacity v2.0.0 Debian Wheezy, AMD 64, Mate DE

When I somehow got v2, I may have downloaded it as an upgrade or it was done for me before I stopped upgrades from synaptic.

The problem I am having is many of the effects have stopped working or behaving very strangely. As an example Noise Reduction will either squash the section into about one quarter the space and make everything white noise or take everything down to zero audio.

Even the engine itself is acting very strangely. For a recording I had to use Ardour to record then try to edit in Audacity which is not working correctly and at times the menu headers will disappear (File, Edit, View, Transport, Tracks, Generate, Effects, Analyze, and Help.)

This is more than a lazy refresh, because the menus will not open when clicked by moving the cursor to the position.

There seems to be a memory problem, too, where some effects will say there is not enough room to make the change.

This makes using Audacity very difficult and has caused me to avoid doing requested productions.

I presume you mean when you close Preferences.
That’s a known bug in WxWidgets 2.8.12
The issue has been recently fixed and should be available in the soon to be released 2.8.13
There is also a patch available so hopefully the maintainers will patch Wx shortly.

The other issues I’ve no idea about. I’ve not seen those problems on Squeeze and not heard of them elsewhere, but they sound to me like symptoms of problem going beyond Audacity.

I have an update about these problems. It appears that most of these issues go away after saving the file, not as an Aup file. I used wav. Then if I close and reopen the file most issues disappear. Also for some reason the ‘snap to’ was checked. I never check this box.

Noise Removal, something I use to take out room noise with a microphone recording is still messed up. If need be I can post examples and photos. It is a little disappointing that this version is so messed up. It should still be labelled experimental and full of bugs. I know they will be fixed, but some important key features are not yet usable.

For example, I cannot save audio in a wave format with anything other than 16 bit. The editing is done with 32-bit floating.

Mayb I should go back to the previous version?

I like it for new users that you have incorporated the lame library into Audacity. Sometimes with Linux it is difficult to load the libraries unless you are willing to go to SID in Debian.

I will spend some time with Audacity today to see which features are still messed up and do unusual things. Luckily we have control z to undo.

I know that I am not as exact as everyone wishes, but there are many issues and I will let someone that is helping me to decide which area to address first.

I have been using Audacity from almost day 1 of it being created. The improvements have been constant and for an overall work-horse audio software, I believe there is none better, even when comparing to the expensive commercial packages.

That’s strange as the default set by the source code is “snap to: off”.

Again that’s strange as there are millions (literally) of people using Audacity 2.0 and you are describing multiple bugs that are completely new with no reports on the bug tracking system.

We haven’t.
Due to licensing issues around MP3 encoding we are not able to include the lame library in Audacity. We are able to include support for lame, but not lame itself (or FFMpeg) which is why they are separate downloads from third party sites:
If you have lame included then someone else put it in. It is not included in Audacity.

The Audacity build that you have appears to be badly broken.
Are you able to check in your package manage to find where it has come from?
The Audacity team do not provide binaries for Linux, just the source code, so someone else has packaged it and there appear to be major problems with that build.

In the Export dialog, choose “Other uncompressed types”, then click the “Options” button, then choose the header and encoding you want in the Options dialog.

– Bill

I’m sorry for taking so long to respond. This memorial holiday I was offered my help to extended family without my knowing. If I had, I would have waited until after the holiday to post.

I am very happy and encourage others to use Audacity. I cannot understand why for most editing, Audacity is not the choice for newbies and professionals.

I will answer in the order shown. If anyone wants photos or samples I will be glad to post.
The menu headers after some editing and many different windows opening and closing will wind up with only 'Fi ’ of file will be visible. The rest of the memu headers are gone and the links with them. It means I will have to save my work and back out of Audacity and reenter. If I have several open windows, editing different files, the effect will happen across all the editing windows. I haven’t been able to figure out when it happens.
I understand the licensing issues with lame and MP3, this is why I am surprised that the Library feature is no longer in preferences. I had to go to another computer to see that on that version Audacity did have library settings. That’s why I am surprised that it was bundled together. Not a complaint, just surprised.
Broken Package?
You could be right about a broken package. This is why I yelled, not in anger but confusion. I have two sources.lists that I switch back and forth by corrupting the name of the list not currently being used. The small list with only a few things turned on and a second one which I will show below that includes the minimal list. The sources.list I do not use is marked with a semi-colon [;] for the everything and a plus sign [+] for the minimal list so that I can keep both configurations in the etc/apt folder. When I swap out a list, I then refresh in Synaptic to acitivate the list.The shown sources.list is only for when I want to download a specific program and not left in place all the time.
I’m sorry I can’t remember that I specifically downloaded v2. I would imagine though from how I tend to do things is that it might have come from the Audacity site. I’m not blaming, but if we have a corrupted package out on the Internet, we need to get it off as fast as possible.


deb cdrom:[Debian GNU/Linux 6.0.3 Squeeze - Official Multi-architecture amd64/i386 NETINST #1 20111008-20:04]/ squeeze main

deb cdrom:[Debian GNU/Linux 6.0.3 Squeeze - Official Multi-architecture amd64/i386 NETINST #1 20111008-20:04]/ squeeze main

Debian security updates:

deb squeeze/updates main contrib non-free
deb-src squeeze/updates main contrib non-free

deb squeeze main contrib non-free
deb-src squeeze main contrib non-free
deb-src wheezy main contrib non-free

Debian US mirror:

deb squeeze main contrib non-free
deb-src squeeze main contrib non-free

Debian Multimedia squeeze:

deb squeeze main non-free
deb-src squeeze main non-free
deb stable main
deb-src stable main
##TESTING testing:

deb testing main contrib non-free
deb-src testing main contrib non-free
deb unstable main contrib non-free
deb-src unstable main contrib non-free


deb sid main
deb testing main
deb wheezy main
deb-src wheezy main
deb testing main
deb-src testing main

It won’t be for a couple of days before I can take the time to do a fresh download from Audacity site. I will let you know the outcome.

If sometimes things are not used, they are forgotten. Thank you for not laughing about how to change the bit rate in exporting wave files. I will use this lesson when I talk to people about using forums. (I don’t help on forums. I do better helping hands-on and to promote Audacity. That is how I give back.)

Thanks to everyone for helping out on this posting.

This is a known problem with WxWidgets 2.8.12
(see my previous post)

The way that Audacity links to LAME and FFMpeg has been updated so that in most cases if FFMpeg and LAME are installed then Audacity will find them automatically. This means that in many cases the “Libraries” preferences settings are not needed and I’m aware that in recent Ubuntu builds those options have been removed from preferences.

It wasn’t from the Audacity site. We don’t offer Linux packages, just the source code.
This is the Audacity web-site download page for Linux:
I suspect that you may be using a Ubuntu build.
Although Ubuntu is based on Debian it is becoming increasingly different and there are no guarantees that Ubuntu packages will work correctly on Debian.

I would suggest that you try installing Audacity from the Debian (Sid, Wheezy or Squeeze) repository. If you still have problems then the best option will probably be to build it from source (it’s quite easy to do on Debian and we can talk you through it if required).

I do appreciate your strong support. The engine itself and the forums far surpass the most popular commercial editors, in quality and support.

I went and retraced my footsteps and yes I did download v2. At the time Debian did not have it in the repos so I used Ubuntu. Debian now has Audacity in the repos and I unintalled and reinstalled through synaptic. I checked to see if my setting were the same in preferences, they were. When I closed out of preferences the only thing showing on the menu was part of the word file. This is v.2 version. I haven’t had a chance to try out different things yet, but it might be important to review some of the different packages and see if I am a fluke because of the way my computer is configured, or it this is a real issue that is starting to happend.

I will try compiling first, have done some of this in the past. If I need help I will come back and ask for help. I will label this solved even though all the issues are not completed. If I get Audacity built myself and it removes these issues. I will come back and note this.

Thank you and keep up the good work.

These steps work on Debian:

  1. sudo apt-get install subversion
  2. svn checkout audacity-read-only
  3. sudo apt-get build-dep audacity
  4. cd audacity-read-only
  5. ./configure
  6. sudo make install

Note however that there is currently a small bug in the svn code that may cause keyboard shortcuts to be lost intermittently (reset them in Preferences if this happens).

That bug does not occur with the release version (2.0.0, available here:
The easiest way to satisfy dependencies is with

sudo apt-get build-dep audacity

The “disappearing menu” issue will still happen if you build against an unpatched version of WxGtk 2.8.12
See near the end of this bug report if you need to patch Wx