Project saveAs sets destination folder to read-only first

Win 7, Version 6.1.7601 Service Pack 1 Build 7601 on a desktop computer.

Installed Audacity v2.1.2 from .exe to a secondary, internal HDD on the main bus in (non-primary, e.g., not C:, but also not a remote or USB connected drive). (Root drive nearly full. All other software installed this way has operated correctly so far.)

Attempting Save Project As to same non-root drive. The source is a 24/96 two-channel .wav that is about 1.4 GB in size.

Even the default, well formed project name generates the “Could not save project. Perhaps D:. . . is not writable or the disk is full” message. Well, the disk has 1.5 TB free, so I guessed perhaps the directory is not writable, heh.

When I investigated, the directories were created, but they had all been set read-only, and so was the target (parent) directory. Apparently, this is happening before Audacity attempts to write. It is not a full read-only, but shows as a solid blue block rather than a check mark.

I quixotically removed the read-only attribute from the affected set of directories, and they were set back to read-only on the next save attempt. I also tried a new directory at the root of the same drive, but with the same result. I also tried saving to a directory on the primary drive, since I think the project data would be small enough to fit there (still have about 80 MB left), but again with the same result.

Perhaps there is a special user permission I have to set for the parent directory. If so, what is the user name I should use and how do I set that up?

Update: The above scenario was for an import with copy.

Imported the audio file without copying, and was then able to save project (also without copying). Not sure what actually gets saved this way, but at least when I start laying on tracks, I can (I think) get started again without having to re-import every file.

Still wondering how to get this working with copying, so my basic question still stands.

Ensure that you are saving to a location that is part of your “user space” (such as “My Documents” or the “Desktop”).

Thanks. Not sure what exactly can be considered part of the user space if not on the primary drive, but since I need to use the secondary drive, I added a directory there in the collection of Library locations, specifically in the Documents collection, and experienced the same problem when saving a project there.

I still suspect thus that the solution resides in giving Audacity one or more special file system permissions, but don’t know how to do this,
which Audacity process needs this permission, or how to name/identify that Audacity process to the OS.

This a common cause of confusion, but the “Read-only” attribute does not apply to folders, only to individual files, and that is the meaning of the “square block”. Therefore that block will always appear inside the “Read-only” option for a folder when you open its Properties, whether you previously set its checkbox to “Read-only” enabled (checked) or disabled (no checkmark).

To see the actual permissions that each user has on that folder, click the “Security” tab in the folder Properties.

Are you running as administrator on this machine? I have the alpha development build of Audacity installed (using our Windows installer) on a partition other than Windows is installed on and don’t have permissions issues.


Thanks, Gale, both for clarification of Win permissions and your suggestion! After launching Audacity as administrator, everything works as expected. It was kind of dumb of me not to think of that, I guess, since that’s one of the usual cures for whatever ails a program, and I’ve used it before, but it would surely be nice if there were a sentence in the user guide about it.

Admin – this thread’s ready to close, now.

It isn’t necessarily required to run Audacity as admin, but it depends where you want to save to and the permissions that exist on that target folder.

Normally you should as a standard user be able to save anywhere in a partition/drive that Windows is not installed on (I have not tested this recently for Audacity - we have had problems in the past with saving to files or folders in the top level (root) of a partition/drive other than C:).

Standard users normally only have Read, Read & execute and List folder contents permissions on the root of C:\ and on C:\Windows and C:\Program Files (or C:\Program Files(x86).