Project file size very large...

The .aup3 file on my project is over 3 Gigabytes (Audacity 3.0.2). This is for 9 audio tracks.

If I export the 9 tracks and bring them back into a blank project and save it… the project size is around 840 Megabytes.

Is there a way to save a project with just the tracks, or to compress the project when saving, to avoid such a large file size?

The same extremely large file sizes appear to occur on all of my projects. Am I doing something wrong?

What other information is Audacity saving, that makes it so large?

Thanks for any assistance!

What is the exact name of the file, including the file path?
(Example: “C:\User\howard\Documents\Audacity\MyProject.aup3”)

“C:\Users\theho\OneDrive\Work\Projects - Current\Didn’t We - (Eb 91 Master).aup3”

By the way, after just making some level changes on a few of the tracks, and saving the project, the size of the file jumped from 814 megabytes to 1.718 Gigabytes!

There must be something wrong here!


Yes there is. It’s a bug that has been fixed in the next version of Audacity, which we hope will soon be available for download.

The problem is the apostrophe in the file name: “Didnt We”

Ensure that Audacity is not running, then make a copy of the project, ensuring that there are no apostrophes in the file name or file path.
Open the copy in Audacity, make a change to the project (such as generating some audio into a new track), then undo the change (“Ctrl + Z”), then save the project and shut down Audacity. You may need to wait while Audacity “compacts” the project.

How big is the copied project after doing that?

Thanks for your reply. I did exactly as you said, and it stayed the same size!

You may need to do a bit more to trigger the compaction.
Again with the copied project, try reversing a long’ish track, then reverse it again so that it’s the right way round, then Save the project and exit.

Did that, and a few other things. Saved and exited. Same large size.

What is the full Path + file name now?

Same as before, minus the apostrophe.

Is that the Microsoft cloud storage?
If so, try moving it out of there to a “normal” folder.

As far as OneDrive, cloud storage… the file was residing on my C drive.
But, I put it in a temp folder on my Desktop with the same results. Same issue.

I’ve exported the tracks and imported them into a blank project again, and save it with a file size 814 megabytes again.
Am giving up for now, hoping the next version will be available in the near future, with a fix. I will avoid apostrophe’s for now.

Thanks for trying!

I don’t know if this helps on this matter, but the dialog box “Compacting Project” doesn’t come up when exiting the program, except on rare occasion. And when it doesn’t come up, a large amount is added to the file length for just some volume changes. Would it be possible to add a function to force “Compacting”? Thanks!

It “should” happen automatically, but it seems that something is stopping it for you.
The presence of an apostrophe is known to stop compacting from working (this has been fixed for Audacity 3.0.3).

“Cloud” drives could also be a problem (they attempt to keep the local and remote copies synchronised, which is likely to cause problems).

As I had mentioned,. it happens on my un-synchronized C-drive folder, with the apostrophe having been eliminated from the file name. So again, it would be nice to have an option to manually initiate compression of the file. Thanks!

Yes, I understand that, but Audacity “should” be compacting automatically. Is it doing so for new projects that are in normal directories and don’t have apostrophes?

Would it be possible for you to upload a project that is not compacting so that we can investigate further?

Sorry, I had extracted the tracks and imported them into a new project and deleted the “Hog” file, before I saw your response. If I encounter the issue again I will save it. Thanks for your response.

Hopefully not, but if you do encounter the problem again then yes please do let us know.

Windows 10, Audacity 3.03

Over 100 audacity files, all music, typical length 4-5 minutes.

The change from .aup to .aup3 really clogged my system, eating about 30GB of drive space in a few days. When you open an .aup it converts the file to .aup3. That takes 3-5 minutes depending on file size for each file. The typical .aup3 file size is 800-1000KB. The typical .aup folder is the same size, so you now have double the storage. Yes, you can delete the .aup but only if you have already converted the file.

In addition, a new feature of this version is “file compacting.” The implication being that the output is being condensed, ie made smaller. This morning a 4.5 minute song track took over 20 minutes to compact (see attachment). No choice but to wait until it is finished to continue the project or move on.

My experience is that since the conversion to .aup3 everything is slower (open, close, compact, etc.), I get a lot more recording drop outs, I get a lot of play back stops with the stop button freaking out by itself. I have used audacity for over three years for music production, even though I have DAWs like Studio One, because I know how to use it. But now it is slowing me down, so maybe its time to move on to a real DAW.
compacting run time.png

Yes, the first few releases of Audacity 3.x can be very inefficient.

Try updating to Audacity 3.1.0, and update as soon as possible for the next couple of releases - There have been some significant improvements to AUP3 project efficiency, and more on the way.

Windows 10 Audacity 3.1.2

I’m having the same problem - Audacity rarely compacts on exit - I have no apostrophes in the file name and it’s not synchronised (just on my C Drive). Last night my project file was half a megabite, today I added 2 more tracks and the file is now 4.8gb. The project has 6 tracks, total length 30 mins - almost all is speech (so mono tracks) with about half a minute of stereo music. Previous half hour project files have been between 700mb and 1.5gb for a similar number of tracks/length.

Today I copied all the tracks into a new project file and the file size was 5.3gb. What am I doing wrong?

That file size is going to eat my storage in no time!