Project crashed while saving, can't open again [SOLVED]

Hello,
I’m having this error the second time. Last time it was easier to make a record again, now it’s more than an hour of voice record.
I was editing (just deleting bad pieces) the recorded file (about 1 GB, and I have more than 200 GB available space), and Audacity crashed while I was trying to save it. First time I was able to relaunch the project, next time it crashed again while saving. Now I can’t open this particular project - Audacity just quits/crashes silently after clicking OK on the welcome window. Below the welcome window I see that the data is in place, the program just can’t read it and quits.
Is there any possibility to eliminate the error in the project which will let Audacity open it?
Audacity 2.0.1
OS X 10.10.5 Yosemite

Last time it was easier to make a record again

Are you keeping safety copies of all your recordings? You should never need to live record something again. Open up the backup show or a copy of the backup show and use that to find out what’s wrong.

No, Audacity should not do that, but errors like this just kill people who step on their old filenames while they produce their show. If you have a complex or large show, the combination of play and record at the same time may cause instabilities.

Audacity 2.0.1 is very old. You can get the latest Audacity version here:

http://audacityteam.org/download/mac

Koz

If you mean just making another copy of recorded file, then no, I didn’t make a backup copy for that, and that’s something I’ll definitely do next time.

It is a long shot, but you could attach the AUTOSAVE file Audacity is trying to recover from. Use Go > Go to Folder in Finder and type this:

~/Library/Application Support/audacity/AutoSave

The AUTOSAVE file is in that “AutoSave” folder.

Please see here for how to attach files: https://forum.audacityteam.org/t/how-to-attach-files-to-forum-posts/24026/1


Gale

Hi Gale,
Thank you for the reply. Sorry it took me so long to return here.
The AutoSave folder is empty. Definitely no hidden files, checked through Terminal…

From your description below about seeing below the Welcome screen that the data was in place, I thought you had been seeing the “Automatic Crash Recovery” dialogue when you launched Audacity:

So if there is no AUTOSAVE file, are you trying to open an AUP file that you had saved before the save that crashed?

If there is an AUP file, you could attach that (though it is still a “long shot”).


Gale

Do you have a Fusion drive in your Mac?

No it’s just the standard welcome screen of the program.

I suppose Audacity tried to save into that file and crashed before the saving process was finished. So I have only one AUP file.

Here is the link to the project archive, though I think that it really doesn’t worth your time…
https://www.dropbox.com/s/sbizxnwppbwkrhw/Archive.zip?dl=0

It’s a 2010 MacBook Pro, so no(

There will only ever be one finished AUP file if you save to the same project name. The AUP file is saved last, after the _data folder is updated.

On Windows at least, the name of the AUP file and _data folder are a mass of strange symbols. However the project does open and correctly display the audio data listed in the AUP file (107378688 samples, or just over 40 minutes of stereo audio, so not over an hour as you said).

There are 358 “orphan block files” which are in the _data folder but not listed in the AUP file, which will be about another 18 minutes of audio. Those orphans will be listed at Help > Show Log… if and when you can open the project. It is possible to rename and recover orphan block files manually if they are actually part of a continuous recorded sequence that was never edited, not otherwise.

This does not explain why Audacity on your machine crashes when opening the project but did not do so first time after the crash. Perhaps before reopening the project you could try resetting preferences. Do this by quitting Audacity, opening Finder, choose Go > Go to Folder and type:

~/Library/Application Support/audacity/

In the “audacity” folder, delete the file “audacity.cfg”.


Gale

It’s because the title of the project was written in the Cyrillic alphabet :slight_smile:
40 minutes - I guess it’s what’s left after I deleted some parts and tried to save it.

Got it.

I really don’t know what was wrong with the outdated version of Audacity I’ve been using, but I’ve just downloaded the latest one and with it I was able to open the project. Thank you for your help and for your time, Gale!