Problems With Keyboard Input

So I’ve been wanting to use my keyboard to play music directly onto my computer. I know there are other programs that can do this, but I heard it is possible with Audacity too.

I have a Casio WK-1630 connected to my computer by a USB MIDI cable. Now I know Audacity is not capable of MIDI input, but what I wanted to do was record directly from the keyboard as sound and not a MIDI. That’s when I found this page and followed the instructions where it said to check the “Software playthrough” box. And it worked! Sort of…

When I clicked Record and played a note on my keyboard, (My keyboard’s volume was all the way down so it could only be heard through the connection) The sound did go through, but the note continued to play VERY LOUDLY after I let go of the key, until I stopped recording!

The keyboard works fine with MIDI input, but it clearly doesn’t like this new method. Anyone know what I’m doing wrong and how to do this properly?

Audacity Version: 2.1.0
Operating System: Windows 8.1

If I had to guess at it, I would say you established a feedback pathway, like the band that doesn’t know how to run the microphone at the club? …eeeeeeEEEEEEEE. Once started, you’re basically irrelevant to the process. The down side is you can’t use this process for music.

I admit this is the first time I’ve heard of someone doing this without MIDI. But then, you haven’t done it yet.

What happens if you turn off Audacity > Edit > Preferences > Recording > [_] Playthrough (de-select). You won’t be able to hear what you’re doing, but play a test anyway. Did the feedback sound go away?


Yes, but now it’s not recording the keyboard’s input at all. I think you were right that it was only feedback I was hearing. I just didn’t recognize it as feedback because I was literally trying to imitate a theremin sound with my keyboard, so I had the instrument set to “whistle”. It sounds just like a microphone screech, on purpose. It’s discouraging though, now that I know it wasn’t recording anything from my piano after all.

If I can’t get this to work, I can always use another program and record with Stereo Mix, or just record it old-school with a microphone.

So did you connect to the mic port of your computer, or much preferable, to the blue line-in if you have that? If you do that, as the blog forgets to point out, you must actually choose the computer input you are connected to in Audacity’s Device Toolbar.