Problems with DAW software and effects after breakdown


I’m using Audacity 2.1.2 on my laptop which still runs on Windows Vista 32 bit. My DAW is TC Electronic’s Impact Twin connected with firewire. This went well for years. Recently I made a large processing operation on Audacity which made my laptop overheat and the adapter broke. A bit before I had downloaded ‘Ample Bass P Lite II version 2.3.1’. I don’t know if it made a difference - it might be more demanding - but I just mention it. I uninstalled it now. Anyway I got a new adapter and the laptop worked as before.

BUT since then I encountered problems with my DAW. The software can not find the device anymore. I changed driver’s software but the same problem. Now I put back the TC Near 3.2.0 software, on which everything still worked well. Unfortunately I have an extra problem instead: the effects that come with the driver’s software won’t settle anymore in Audacity. One effect (Assimilator Native) opens up with everything there but it is disabled. It shows up twice in the audacity effect list. With the other three (M40 Reverb, Integrator and Resfilter Native) I get the message ‘Trying to initialise the following effect failed’. I see the effects their dll’s are just standing in the Steinberg vst map as before.

The only thing I still can replace is my cable (s400 to 600). I get a new cable in a few days. But I think this doesn’t account for the loss of effects.
Would be very glad if someone got me out of this. Regards,


Ample-Bass-P-Lite-II” is only available as a 64-bit plugin, so cannot work on 32-bit Audacity/Windows.

By installing an incompatible plugin you may have corrupted the plugin-configuration files,
and that corruption is now preventing other effects from operating in Audacity.

If you rename




Then restart Audacity that will generate new (empty) versions of those configuration files, that may solve the problem. [ If it doesn’t, you still have the “-old” versions to revert to ].

Those files are in a hidden folder called AppData…


So can persist after reinstallation.

Audacity 2.1.2 is obsolete. The current version is Audacity 3.1.3, but according to the Audacity website the only versions of Windows that are supported are Windows 10 and 11.

Windows Vista has been obsolete for 5 years.

What “adapter”? Has it been replaced or repaired?

What is your “DAW”?
(“DAW” stands for “Digital Audio Workstation”, and usually refers to audio production software such as Cubase, Sonar, Reaper, Logic Pro …)

Reading through your post, it sounds like “nothing works properly any more”. I doubt that we will be able to help you very much. The real solution would be to upgrade everything to current, supported versions.

I don’t know how much it will help, but you could try doing a clean install of Audacity 2.1.2 (as you say that version worked previously on your antique system). To do a clean install:

  1. Uninstall Audacity.
  2. Delete the hidden folder: C:\Users**\AppData\Roaming\audacity**
  3. Reboot the computer
  4. Reinstall Audacity.


Thanks for the expertise both!!

I installed ‘Ample-Bass-P-Lite-II’ on my laptop and it worked well so maybe I found a 32-bit version. But I uninstalled it after the breakdown of the power adapter as I thought it could’ve had a bad influence.

I followed your advice Trebor, I renamed these files (‘pluginregistry-old.cfg’ ‘pluginsettings-old.cfg’). It cleaned up the add-list from some old effects that I had deleted but had remained in that list. The assimilator native effect had two lines in the effective list and now has one. The other three effects appear as new in the add-list but I can’t switch them on - they don’t appear in the effective list.

About DAW Steve, I’m sorry I misexpressed that. I meant my audio interface (TC Electronic’s Impact Twin) which can’t be found by its software anymore after the breakdown. I replaced the power adapter by another and everything works as before again except the audio interface and its effects although the effects still worked shortly after the replacement.

The DAW I thus use is Audacity 2.1.2 and this works well on my vista laptop. It’s enough for what I want to do and I use the laptop basically only for that. We have a newer pc for family use but I prefer the old file backup system.

Hope all is clear now.

This occurs if the plugins are incompatible with Audacity, e.g. 64-bit plugins on a 32-bit machine.
[ VSTi (instruments) & VST3 are incompatible with Audacity].
https ://

Impact Twin plugins are on VST format. The software installer is x86. I got the 3.2.0 software advised from the old support desk. The Impact Twin works on Vista. Unluckily for me the support crew has been renewed and the former forum has been closed.

The effects worked for five years on Audacity so if they were 64-bit and incompatible they couldn’t have worked could they?

I tried some older software versions but set it back at TC Near 3.2.0. Maybe I will try another reinstall… But I think, like you said, something is hindering these effects… I have used Clean Master and Ccleaner to clean leftovers after these installs…

VSTi* (32 or 64 bit) plugins may work on the software which came with your audio interface,
but will not run in Audacity. Similarly for VST3 plugins, (32 or 64 bit), not going to run in Audacity.

[ * The bass-guitar emulation you mentioned is VSTi plugin, (VSTinstrument), those will not run in Audacity ].

It’s possible that you, (like me), have a 64-bit computer, running an old 32-bit version of Audacity.
and you could record the stand-alone version of the bass guitar emulation output using Audacity,
but that VSTi is not running in Audacity, it’s a stand-alone running in tandem with Audacity.
VSTi plugins cannot be installed in Audacity.

Yes, to be clear I had the Ample Bass running on the laptop but not in Audacity. That’s the difference with the TC Electronic effect plugins. These worked IN Audacity!

When you replaced the years-old “adapter”, (audio interface),
the software & plugins which came with the new one may be 64-bit versions of the old plugins.
If you (like me) are running an old 32-bit version of Audacity, 64-bit plugins cannot run on it.
Now the good news: the latest version of Audacity is available in 64-bit, so can use some 64-bit VST plugins.
Now the bad news #1: 64-bit Audcaity will not run 32-bit plugins.
Now the bad news #2: The latest 64-bit Audacity has had a makeover since 2.1.2: it has new tools to be learned.

??? Is this spam? New user… ???


Yes, it is. Thank you.

So, it took me some time to get me a new firewire cable for the audio interface, the right one! A ‘Belkin’ cable thus and the software now recognised the interface. Also Midi In and Out were found again.

It helped a little bit for the Steinberg effects of the interface’s software: one effect now works in Audacity (the one that was ‘disabled’ before).
The other three effects Audacity can’t seem to load. I am thinking of installing Audacity 3.1.0. and copying my plug-ins into it. We’ll see

I have a problem updating to Audacity 3.1.0 or earlier versions in Vista. I can’t open the setup.exe not even as an administrator. I read this has to do with permissions. Anyone knows what these permissions are and how I can receive them to make the 3.1.0 setup work?


Windows Vista is obsolete and no longer supported (Windows Vista - Microsoft Lifecycle | Microsoft Learn).

You could try Audacity 2.4.2 and see if that works. It’s available here: Old Audacity versions download


I can’t open these setups anymore but how can the people of Audacity know Vista works until 3.1.0 ?? They made these setups work in this system…

They don’t. There has been no official testing of 3.x on Vista.

From Missing features - Audacity Support

The current Audacity version is no longer supported on Windows Vista, it may well run - but we can no longer offer support for issues that occur when using Audacity on Vista.

Note that it says “it may” not “it will”. Your experience suggests that it doesn’t. I can’t test myself as I don’t have Vista.